Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14920 - Eclipse crashes after upgrade to 3.4.2

Attached to Project: Arch Linux
Opened by David Rosenstrauch (darose) - Tuesday, 02 June 2009, 14:06 GMT
Last edited by Hugo Doria (hdoria) - Wednesday, 03 June 2009, 14:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After upgrade to Eclipse 3.4.2, the IDE crashes with the following error:
[darose@daroselin ~]$ eclipse
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.core.jobs; bundle-version="[3.2.0,4.0.0)"
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:265)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:257)
at org.eclipse.equinox.internal.simpleconfigurator.ConfigApplier.startBundles(ConfigApplier.java:317)
at org.eclipse.equinox.internal.simpleconfigurator.ConfigApplier.install(ConfigApplier.java:86)
at org.eclipse.equinox.internal.simpleconfigurator.SimpleConfiguratorImpl.applyConfiguration(SimpleConfiguratorImpl.java:124)
at org.eclipse.equinox.internal.simpleconfigurator.SimpleConfiguratorImpl.applyConfiguration(SimpleConfiguratorImpl.java:138)
at org.eclipse.equinox.internal.simpleconfigurator.Activator.start(Activator.java:48)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:1009)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:1003)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:984)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:355)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1074)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:616)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:299)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.launch(StartLevelManager.java:247)
at org.eclipse.osgi.framework.internal.core.SystemBundle.resume(SystemBundle.java:201)
at org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:644)
at org.eclipse.osgi.framework.internal.core.OSGi.launch(OSGi.java:51)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:313)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
at org.eclipse.equinox.launcher.Main.main(Main.java:1212)

(.:11652): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed
This task depends upon

Closed by  Hugo Doria (hdoria)
Wednesday, 03 June 2009, 14:17 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Problem is not a bug, but an incompatibility between new version and existing ~/.eclipse directories.
Comment by Ionut Biru (wonder) - Tuesday, 02 June 2009, 14:58 GMT
move your settings and try again.
mv ~/.eclipse ~/eclipse_backup
Comment by David Rosenstrauch (darose) - Tuesday, 02 June 2009, 15:10 GMT
Ah. Yep - fixed the problem. Sorry for the noise.
Comment by Vladimir Dranyonkov (los-t) - Tuesday, 02 June 2009, 19:08 GMT
No total fix for me. Eclipse started only once and tried to update itself.
With no results. Can't get it working now. It just hangs up without any output to console.
Comment by Vladimir Dranyonkov (los-t) - Tuesday, 02 June 2009, 19:17 GMT
Removing the ~/.eclipse helped again. But updates won't work from inside eclipse.
I am using a clean eclipse installation now.

I get this thing while trying to install packages using elcipse' site manager.

An error occurred while collecting items to be installed
No repository found containing: com.sun.jna/osgi.bundle/3.0.9
No repository found containing: com.sun.jna/org.eclipse.update.feature/3.0.9
...
No repository found containing: org.tmatesoft.svnkit/osgi.bundle/1.2.2.5405
No repository found containing: org.tmatesoft.svnkit/org.eclipse.update.feature/1.2.2.5405

After it eclipse hangs up on next start.

Loading...