Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14903 - [openssl] About perl dependency

Attached to Project: Arch Linux
Opened by Kyle Keen (keenerd) - Monday, 01 June 2009, 04:48 GMT
Last edited by Pierre Schmitz (Pierre) - Wednesday, 17 June 2009, 16:56 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:
openssl requires Perl for two scripts: CA.pl and c_rehash
CA.pl is only used on Windows, (Linux uses CA.sh)
c_rehash is used by ca-certificates to name symlinks, but is owned by openssl.

Suggest perl be moved to optdeps for openssl and added as a dep to ca-certificates.


Additional info:
http://bbs.archlinux.org/viewtopic.php?id=73200


Steps to reproduce:
cat /var/lib/pacman/local/openssl-0.9.8k-2/files | xargs file | grep perl
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Wednesday, 17 June 2009, 16:56 GMT
Reason for closing:  Won't fix
Comment by Kyle Keen (keenerd) - Monday, 01 June 2009, 05:01 GMT
Alternatvely, replace it with a shell script:

http://mail-index.netbsd.org/tech-crypto/2005/11/17/0000.html

Maybe not that exact one since it is 4.5 years old.

Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 01 June 2009, 13:23 GMT
This is very interesting for minimal chroot for example, when need to install with pacman -r a set of base packages :) and need openssl libs, but not perl
Comment by Greg (dolby) - Monday, 01 June 2009, 13:34 GMT
http://bugs.archlinux.org/index.php?events%5B%5D=1&fromdate=&todate=&event_number=50&project=1&do=reports&submit=
Very weird. This bug report appears in opened more than 20 times, and it also appers to be opened by another user. Sorry for offtopic.
Comment by Greg (dolby) - Monday, 01 June 2009, 13:34 GMT
Also see the History tab above.
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 01 June 2009, 13:39 GMT
Yes, I noticed that. Also in the events section, looking for the user 'ate' he has 0 messages.
Comment by Kyle Keen (keenerd) - Monday, 01 June 2009, 15:00 GMT
That is weird. I had the "new bug page" open in Opera during that time. Some sort of misguided automatic draft saving?
Comment by Pierre Schmitz (Pierre) - Tuesday, 02 June 2009, 19:52 GMT
I don't think it's worth to "hack" on deps just to save some bytes in some rarly used chroot environments.

Removing a dep from such a basic pacakge means that we need to recheck all deps of packages that directly or indirectly depend on openssl.
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 03 June 2009, 04:59 GMT
@Pierre: OK, I understand could be the severity of removing it. Thank you.

Loading...