Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14872 - abiword fails to open .odt files

Attached to Project: Arch Linux
Opened by Giuseppe Borzi (gborzi) - Friday, 29 May 2009, 14:22 GMT
Last edited by Anonymous Submitter - Friday, 29 May 2009, 15:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Abiword fails to open .odt and .sxw files, after the update to version 2.7.2 from 2.6.8.
On some files Abiword's window shows only a few messed up characters, on some other files abiword takes 100% CPU and must be killed. The files I've tried to open with abiword are very simple, generally only a few lines of text without tables and/or figures. Abiword version 2.6.8 opened these same file without any problem.
According to the bug report in http://bugzilla.abisource.com/show_bug.cgi?id=11231 the problem is due to the lack of abiword-plugins. I have this package installed, but it is at version 2.6.8, so it seems that version 2.7.2 (which is a dev release) can't use older plugins. I suggest to downgrade to 2.6.8.


Additional info:
* package version(s) 2.7.2 from 2.6.8
* config and/or log files etc.


Steps to reproduce:
Open the attached file avviso.odt
This task depends upon

Closed by  Anonymous Submitter
Friday, 29 May 2009, 15:58 GMT
Reason for closing:  Fixed
Comment by Jan de Groot (JGC) - Friday, 29 May 2009, 14:31 GMT
Why was this package updated to a development version in the first place?
Comment by Anonymous Submitter - Friday, 29 May 2009, 14:42 GMT
Hi Jan, I updated it to a development version because abiword 2.6.8 crashes when printing dialog was opened.
So, I fixed a previous bug report about it. (See http://bugs.archlinux.org/task/13746)
Comment by Anonymous Submitter - Friday, 29 May 2009, 14:48 GMT
I also can downgrade it to the 2.6.8 version, but we will got the previous printing bug again.
Comment by Giuseppe Borzi (gborzi) - Friday, 29 May 2009, 15:06 GMT
I've printed from abiword 2.6.8 without any problem, on local and networked printers, starting it from the command line or the menu. I suppose that the problem with the printing dialog arised with older version of libgnomeprint and libgnomeprintui.
Comment by Jan de Groot (JGC) - Friday, 29 May 2009, 15:08 GMT
Can't reproduce it either. The warning printed is coming from libgnomecups, but as said, it's a warning, nothing critical.
Comment by Anonymous Submitter - Friday, 29 May 2009, 15:09 GMT
Hi Giuseppe,

nope, I had the same issue of the  FS#13746  bug report and I cannot print with older and newer versions of libgnomeprint and libgnomeprintui.
See http://bugs.archlinux.org/task/13746
Comment by Anonymous Submitter - Friday, 29 May 2009, 15:11 GMT
Jan, it's not a warning, abiword totally crashes when printing dialog is showed.
Comment by Anonymous Submitter - Friday, 29 May 2009, 15:13 GMT
If you want, I downgrade it to 2.6.8, but I will must open the  FS#13746  again and at the moment I haven't a solution for it.
Let me know.
Comment by Jan de Groot (JGC) - Friday, 29 May 2009, 15:19 GMT
It is a warning, I get that one also. If it would be a fatal one, then it would be logged as CRITICAL. I can't reproduce the bug, so if you can still reproduce this, compile abiword with debug symbols and fire it up inside a debugger.
Comment by Anonymous Submitter - Friday, 29 May 2009, 15:28 GMT
Yeah, sure I can still reproduce this.
I'll be trying to compile abiword like you said and I think is better to downgrade it however.
Comment by Giuseppe Borzi (gborzi) - Friday, 29 May 2009, 15:31 GMT
Hi Giovanni,
I've read the bug report 13746 and the forum thread linked there. I have the following warning when printing

** (abiword:7862): WARNING **: could not set the value of Settings.Document.Filter, node not found

which seems abiword-related. I uninstalled the abiword-plugins package and tried opening the same .sxw and .odt files, and I got the same malfunctions with abiword 2.6.8. There are two options (besides using openoffice/kword):
1) Leave abiword at 2.7.2 and renounce to open .sxw .odt and perhaps other files.
2) Downgrade abiword to 2.6.8 and in the worst case renounce to print, but at least you can open the file. I wrote "worst case" because this bug doesn't affect everyone, perhaps it depends on some configuration option.
Comment by Anonymous Submitter - Friday, 29 May 2009, 15:38 GMT
Hi Giuseppe, I know that.... but I'd like know what I should do about it.
Should we choose the 1) or 2) solution?
Comment by Anonymous Submitter - Friday, 29 May 2009, 15:43 GMT
However, I think that a return to the previous version is the better solution.
Comment by Anonymous Submitter - Friday, 29 May 2009, 15:57 GMT
OK, we return to the 2.6.8 version, so I close this and I open  FS#13746  again.

Loading...