Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14801 - netcfg + dhcpcd + rt73 getting IP failed

Attached to Project: Arch Linux
Opened by Filipp Andjelo (scorp) - Friday, 22 May 2009, 14:45 GMT
Last edited by James Rayner (iphitus) - Tuesday, 26 May 2009, 14:56 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To James Rayner (iphitus)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After upgrading dhcpcd 4 -> 5 getting IP for the WiFi Adapter fails with an error:

dhcpcd: wlan0: ignoring DHCP message; no Server ID
dhcpcd: wlan0: ignoring DHCP message; no Server ID
dhcpcd: wlan0: ignoring DHCP message; no Server ID
dhcpcd: timed out
:: MyNet up - DHCP IP lease attempt failed [FAIL]

Do not know if it is netcfg, dhcpcd or driver error, 'cause on other machine (using wicd, rt2500 adapter and dhcpcd 5) is everything ok. Downgrading dhcpcd 5 -> 4 solved the problem.

Additional info:
* package version(s)
netcfg 2.1.3-3
dhcpcd 5.0.2-1
* hardware
rt73 based WiFi USB-Stick

Steps to reproduce:
Try to init netcfg WiFi profile using dhcpcd
This task depends upon

Closed by  James Rayner (iphitus)
Tuesday, 26 May 2009, 14:56 GMT
Reason for closing:  Fixed
Comment by Alois Nespor (anespor) - Tuesday, 26 May 2009, 11:53 GMT
this is fixed in netcfg 2.2.0b1
Comment by James Rayner (iphitus) - Tuesday, 26 May 2009, 14:55 GMT
No, this is not a bug in netcfg at all, but your dhcp server.

Your DHCP server is not following the RFC and not behaving as it should. In v5, dhcpcd became a lot stricter, hence it complains now. dhcpcd v5.0.4 is in [testing] and it contains an option to allow these dhcp servers.

Loading...