Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14775 - [klibc] missing license file

Attached to Project: Arch Linux
Opened by Eric Belanger (Snowman) - Thursday, 21 May 2009, 01:01 GMT
Last edited by Aaron Griffin (phrakture) - Tuesday, 01 December 2009, 21:43 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas Bächler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The klibc-1.5.15-2 package have the license=('BSD') but this package:

1) Not install any "LICENSE" file like others packages that have "BSD" as license.
2) The LICENSE file include some comments about that some files are GPL2, others are under BSD (original but the note about the clause 3), and others under MIT/X11.
This task depends upon

Closed by  Aaron Griffin (phrakture)
Tuesday, 01 December 2009, 21:43 GMT
Reason for closing:  Deferred
Additional comments about closing:   FS#17298 
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 07 June 2009, 20:59 GMT
oops! klibc-1.5.15-3 in testing don't fix this minor issue. For next rebuild ;)
Comment by Roman Kyrylych (Romashka) - Saturday, 03 October 2009, 18:29 GMT
klibc is going to be removed, so there's not much point to fix this.
"Won't fix"?
Comment by Eric Belanger (Snowman) - Saturday, 03 October 2009, 19:05 GMT
Will it be removed soon?
Comment by Aaron Griffin (phrakture) - Monday, 05 October 2009, 21:31 GMT
Hmmm, Thomas do we have an ETA on the uClibc changes?
Comment by Thomas Bächler (brain0) - Monday, 05 October 2009, 21:43 GMT
I am having trouble compiling the necessary tools. Didn't have time to try again for a few days.

I have PKGBUILDs for mkinitcpio-busybox and mkinitcpio-module-init-tools in trunk, but I cannot get blkid from util-linux-ng to work.

Loading...