Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#1470 - glibmm, gtkmm, libglademm... all *mm needs recompile

Attached to Project: Arch Linux
Opened by t (vidvandre) - Friday, 17 September 2004, 22:39 GMT
Last edited by arjan timmerman (blaasvis) - Saturday, 18 September 2004, 09:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To arjan timmerman (blaasvis)
Architecture not specified
Severity Very Low
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

All the *mm packages + libsigc++2 needs a recompile as they were probably compiled with a previous version of g++.
If you try to compile something which links to any of these
packages, you'll get a lots of "unresolved reference" errors.
This task depends upon

Closed by  arjan timmerman (blaasvis)
Tuesday, 05 October 2004, 14:20 GMT
Reason for closing:  Fixed
Comment by arjan timmerman (blaasvis) - Saturday, 18 September 2004, 07:10 GMT
could you please give me an example how to produce the error?
Comment by t (vidvandre) - Saturday, 18 September 2004, 12:09 GMT
I only have one large program that I'm working on. I guess any of the
examples in the gtkmm source should do.

I recompiled each an every or these packages to solve this. So I guess it's a matter of recompiling with gcc/g++ 3.4.2 to fix it.

Here are some of the errors that I found in my irc log:
libsigc-2.0.so: undefined reference to `std::ios_base::Init::~Init()@GLIBCXX_3.4'
libglibmm-2.4.so: undefined reference to `std::ios_base::Init::~Init()@GLIBCXX_3.4'

got exactly the same error message for the remaining *mm libs.

Another way to reproduce it as I recall it is to try to compile glibmm.
It will refuse to compile until you recompile libsigc++.

Comment by arjan timmerman (blaasvis) - Sunday, 19 September 2004, 10:50 GMT
i have rebuiled libsigc++2.0 so try again and report please ;)
Comment by t (vidvandre) - Tuesday, 21 September 2004, 16:55 GMT
The rebuild libsigc++ works fine. . But as I tried to explain, recompiling only libsigc++ didn't help the program I am working on, as all the *mm packages had to be recompiled as well to get rid of "undefined reference to `std::ios_base::Init::~Init()@GLIBCXX_3.4'" errors.
Comment by arjan timmerman (blaasvis) - Tuesday, 05 October 2004, 11:04 GMT
well glib en gtk also been rebuild allready the rest will follow
Comment by arjan timmerman (blaasvis) - Tuesday, 05 October 2004, 14:19 GMT
ok done

Loading...