Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14699 - [Gconf] crashes Hardware-monitor panel applet

Attached to Project: Arch Linux
Opened by Francisco Pina (Stunts) - Tuesday, 12 May 2009, 15:50 GMT
Last edited by Hugo Doria (hdoria) - Wednesday, 03 June 2009, 14:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
The Gconf-2.26.1-1 and Gconf-2.26.1-2 packages crash the Gnome Panel applet "hardware-monitor" (can be found in AUR).

The error message follows:
'The panel encountered a problem while loading "OAFIID:HardwareMonitor".'

And an option to delete the applet from the panel is presented.

If run from the console, after adding the applet to the panel, and receiving the above error message, the following output is displayed:
'(hardware-monitor:6926): GConf-CRITICAL **: gconf_entry_get_value: assertion `entry != NULL' failed
Segmentation fault'

Reverting to Gconf-2.26.0-3 using arch's rollback system solves this problem.


Additional info:
* package version(s)
Gconf-2.26.1-1
Gconf-2.26.1-2

* config and/or log files etc.
Not applicable


Steps to reproduce:

1. Install hardware-monitor via AUR;
2. Add the applet to the panel;
3. Watch it fail with the mentioned error.
This task depends upon

Closed by  Hugo Doria (hdoria)
Wednesday, 03 June 2009, 14:19 GMT
Reason for closing:  Upstream
Comment by Francisco Pina (Stunts) - Friday, 15 May 2009, 22:29 GMT
Updating to the new version of Gconf (2.26.2.1) does not solve the problem.
Reverting it back to 2.26.0 still does.
Comment by Francisco Pina (Stunts) - Saturday, 16 May 2009, 12:25 GMT
Seems to be an upstream problem.
I have requested testing on Ubuntu which uses Gconf 2.26.2 and it also makes a crash there.
Results here: http://ubuntuforums.org/showthread.php?t=1160961
Comment by Francisco Pina (Stunts) - Saturday, 16 May 2009, 12:56 GMT
Bug submitted to Gnome.

http://bugzilla.gnome.org/show_bug.cgi?id=582865

Should this be marked closed?

Loading...