Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#14660 - [libdownload] x86-64 package in i686 repo

Attached to Project: Arch Linux
Opened by Antti Oja (gigapikseli) - Sunday, 10 May 2009, 08:36 GMT
Last edited by Allan McRae (Allan) - Sunday, 10 May 2009, 08:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No


After upgrade, everything which depends on this library breaks with an error message: wrong ELF class: ELFCLASS64

Additional info:
libdowbload 1.3-2-i686

Steps to reproduce: Run pacman -Suy on i686 system and try to use anything which depends on libdownload, eg pacman.
This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 10 May 2009, 08:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  libdownload 1.3-3
Comment by Antti Oja (gigapikseli) - Sunday, 10 May 2009, 08:46 GMT
libdowbload 1.3-3 has been uploaded to the i686 reposity fixing this problem. Closing.