Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14645 - [vi] (n)vi in testing aborts with international characters

Attached to Project: Arch Linux
Opened by Jan de Groot (JGC) - Saturday, 09 May 2009, 13:22 GMT
Last edited by Tobias Kieslich (tobias) - Sunday, 13 September 2009, 22:33 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Kieslich (tobias)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

(n)vi in testing aborts when you try to enter international characters like ë and ü. Users have reported truncated written files also.

The widechar support in nvi is buggy. Either it should be disabled (--disable-widechar), or it should be fixed. Debian has some fixes for this in their package, but what I've seen from them the result isn't so different from disabling widechar support.
This task depends upon

Closed by  Tobias Kieslich (tobias)
Sunday, 13 September 2009, 22:33 GMT
Reason for closing:  Won't fix
Additional comments about closing:  This is obsolete as we are using ex-vi instead of nvi now
Comment by Devin Cofer (Ranguvar) - Monday, 18 May 2009, 01:21 GMT
Confirmed. Try opening this file in nvi, and compare with vim or any other 'good' editor: http://aur.archlinux.org/packages/bin32-wine/bin32-wine/PKGBUILD
Comment by Davorin Učakar (phantom) - Wednesday, 27 May 2009, 22:15 GMT
It've been looking the nvi code and it seems it converts file from utf8 to ASCII line-by-line. Of course conversions of lines with non-ascii chars fail. I wonder why nvi converts to ascii, since destination encoding is obtained with nl_langinfo and therefore should be utf8 not ascii (if you have set utf8-enabled language in LANG variable). Obviously nvi messes with LC_CTYPE or something similar.
Comment by Tobias Kieslich (tobias) - Thursday, 25 June 2009, 16:35 GMT
I added a patch that displays those characters a hex values (from ubuntu)
Comment by Davorin Učakar (phantom) - Thursday, 25 June 2009, 20:01 GMT
What about to drop nvi and replace it with ex/vi? There's little difference between these two but ex/vi is much smaller and handles utf8 perfectly.
Comment by Davorin Učakar (phantom) - Thursday, 02 July 2009, 10:35 GMT
I've found the problem. The db47-hack.patch (LC_ALL=C or LANG=C imply LC_CTYPE=C) is responsible for the encoding mess I was talking about in my first comment. We must find some other way for suppressing the warning messages.
Comment by Loui Chang (louipc) - Tuesday, 14 July 2009, 23:59 GMT
I vote for replacing nvi with ex-vi. It's smaller, it handles utf8 perfectly,
and they're not planning on adding a silly gtk interface.

http://ex-vi.sourceforge.net/
http://aur.archlinux.org/packages.php?ID=26805
Comment by Zachary Kline (zkline) - Sunday, 26 July 2009, 16:16 GMT
I second that vote.
Comment by Tobias Kieslich (tobias) - Sunday, 26 July 2009, 17:45 GMT
vi in testing IS ex-vi now. please check back if that works for you guys. Thanks
Comment by Smith Dhumbumroong (zodmaner) - Sunday, 26 July 2009, 18:32 GMT
With the current vi package in testing (ex-vi), entering non-ASCII characters no longer crash vi.
Comment by Zachary Kline (zkline) - Monday, 27 July 2009, 00:24 GMT
Agreed, vi in testing seems so far to work quite well for me.
Comment by solsTiCe (zebul666) - Wednesday, 29 July 2009, 11:39 GMT
on this issue ex-vi is clearly better i.e. it works !

Loading...