Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14536 - [xfce4] depends on dbus

Attached to Project: Arch Linux
Opened by David Auinger (David1989) - Friday, 01 May 2009, 14:59 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 17 January 2010, 22:25 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

If dbus is not installed, some base tasks of xfce4 cannot be loaded (xfwm4, xfdesktop, xfsettingsd).


Steps to reproduce:

Some tasks needed for xfce4 are not loaded when package dbus is not installed.

Steps to reproduce:

Remove dbus (if installed):
pacman -R dbus

Install xfce4:
pacman -Sy xfce4

Start xfce4 from console:
startxfce4
   . (0 KiB)
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 17 January 2010, 22:25 GMT
Reason for closing:  Fixed
Comment by Andrew (abrouwers) - Friday, 08 May 2009, 19:14 GMT
I can confirm this; doing a fresh install, dbus does not get pulled in, and xfconfd will complain and not load xfce properly. After installing "dbus" (on top of dbus-core), it works properly. This seems to have come up since dbus was dropped as a dependency for hal.
Comment by Gerardo Exequiel Pozzi (djgera) - Thursday, 08 October 2009, 04:53 GMT
confirmed here. Just recent doing a clean archiso installation.
Comment by Andrew (abrouwers) - Monday, 11 January 2010, 18:19 GMT
*poke* - hit this yet again. I'm not sure which xfce component should have the dbus dep directly (perhaps xfconf?), but it definitely needs to be added somewhere. Any chance to get this included? It hits any user trying to install xfce from scratch, since newer versions of hal will not bring in dbus (only dbus-core, which is not sufficient here) as before.
Comment by Andreas Radke (AndyRTR) - Saturday, 16 January 2010, 09:37 GMT
according to this I will add dbus to xfconf pkg: http://www.xfce.org/documentation/requirements
Comment by Andrew (abrouwers) - Saturday, 16 January 2010, 22:12 GMT
Sounds perfect ! Thanks.

Loading...