Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14491 - mplayer 29188-2 crashes

Attached to Project: Arch Linux
Opened by Sander Jansen (GogglesGuy) - Wednesday, 29 April 2009, 03:13 GMT
Last edited by Jan de Groot (JGC) - Saturday, 23 May 2009, 15:59 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Hugo Doria (hdoria)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

For several files mplayer is crashing. They all seem to have something to do with the audio decoder:

Matroska file format detected.
VIDEO: [avc1] 720x480 24bpp 29.970 fps 0.0 kbps ( 0.0 kbyte/s)
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
FAAD: compressed input bitrate missing, assuming 128kbit/s!
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio))
Player interrupted by signal 11 in module: decode_audio

This task depends upon

Closed by  Jan de Groot (JGC)
Saturday, 23 May 2009, 15:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  Reported as fixed in 29318-1.1
Comment by Chuck (foxcm2000) - Wednesday, 29 April 2009, 15:07 GMT
I can confirm the crash, seems to be related to liba52 on some files I have here. Question: The new mplayer package is compiled with GCC 4.4.0 ... should the supporting media libraries be recompiled with the same version?
Comment by Sander Jansen (GogglesGuy) - Wednesday, 29 April 2009, 15:12 GMT
Possibly. The changelog of GCC 4.4 mentions several ABI changes for x86-64 for certain cases. See http://gcc.gnu.org/gcc-4.4/changes.html
Comment by b4283 (b4283) - Monday, 04 May 2009, 01:28 GMT
I can confirm this error.
The bbs thread containing 2 resolutions, see: http://bbs.archlinux.org/viewtopic.php?pid=546136
Comment by Ben Court (super.rad) - Monday, 04 May 2009, 12:12 GMT
I had same problem (mplayer output in thread above) was fixed by using mplayer-mt-nogui-git from AUR
Comment by Jakub Schmidtke (sjakub) - Tuesday, 12 May 2009, 10:01 GMT
Using mplayer-mt-nogui-git is not really a "fix" ;)

Same problem. x86_64. mplayer-29188-2 is affected, mplayer-29188-1 is fine.
Comment by Ionut Biru (wonder) - Tuesday, 19 May 2009, 10:48 GMT
crashing here when playing mkv movie format.

137 audio & 296 video codecs
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing atb-l.a._nights-dvdrip-x264-2009-se.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_MPEG/L3), -aid 0, -alang und
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO: [avc1] 720x416 24bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3


MPlayer interrupted by signal 11 in module: init_audio_codec
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Comment by Hugo Doria (hdoria) - Tuesday, 19 May 2009, 11:50 GMT
Can you guys try mplayer from [testing]?
Comment by Sander Jansen (GogglesGuy) - Tuesday, 19 May 2009, 14:09 GMT
Why did this package move out of testing btw? Isn't the whole purpose of [testing] to test a package and fix any bug reports that are filed before moving it out of testing?
Comment by Stu (smpmc) - Wednesday, 20 May 2009, 00:11 GMT
I can confirm this, but instead of mp3lib, it was FFmpeg/libavcodec in my test. ...In what repo is there a new version in [testing]? (using Server=ftp://ftp.archlinux.org/testing/os/x86_64 for [testing])
Comment by F.Di Milia (PyCoder) - Wednesday, 20 May 2009, 22:31 GMT
Same here on 3 PC's with x86_64.


Btw: Stu there is no mplayer update in testing.
Comment by Stu (smpmc) - Thursday, 21 May 2009, 02:42 GMT
@Milia Thanks for the heads up. (As you can tell, I'm a bit of a nb in these parts.) I was just under the impression from Doria's earlier post that there was one; making sure I wasn't losing my mind. It happens sometimes.
Comment by Ionut Biru (wonder) - Friday, 22 May 2009, 22:02 GMT
is working here with mplayer 29318-1.1
Comment by Stu (smpmc) - Saturday, 23 May 2009, 13:35 GMT
29318-1.1 is a success here as well.

Loading...