Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#14434 - pacman removes the packages instead of updating them

Attached to Project: Pacman
Opened by Antek Aduszkiewicz (senjin) - Thursday, 23 April 2009, 09:36 GMT
Last edited by Xavier (shining) - Sunday, 26 April 2009, 13:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When a package is replaced with a package of different name during update, and there is some problem with updating any other package, the package is removed from the system without any message.

I upgraded the full system today. I was asked if I want to replace amarok-base and amarok-engine-xine with amarok. I replied 'yes'. But then xorg-server update bug appeared (http://bbs.archlinux.org/viewtopic.php?id=69691) and stopped the instalation. As a result the old amarok packages were removed but the new one was not installed.

Of course it was not a big problem for me, because amarok is not a critical package, but this bug can cause removal of any package of the system... Actually I remember that last year many people (including me) lost coreutils package due to a bug in some nvidia drivers update, which broken kernel as a result. Iirc the bug report was filled and I thought it was fixed, but it seems it was not.


Additional info:
* package version(s)
pacman 3.2.2-1
This task depends upon

Closed by  Xavier (shining)
Sunday, 26 April 2009, 13:30 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Dup of  FS#9088 
Comment by Antek Aduszkiewicz (senjin) - Thursday, 23 April 2009, 09:38 GMT
By mistake I set the severity to 'Low' while it should be 'high', since the bug can seriously damage the system.
Comment by Nagy Gabor (combo) - Friday, 24 April 2009, 16:25 GMT
This is a dup of  FS#9088 , which has been already fixed in git, so this bug should not exist in the next major pacman release.
Comment by Antek Aduszkiewicz (senjin) - Saturday, 25 April 2009, 10:51 GMT
Sorry, that's because I didn't noticed there's a separate bugs section for pacman.

Loading...