Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14432 - iwlagn module doesn't load

Attached to Project: Arch Linux
Opened by Krzemin (krzemin) - Wednesday, 22 April 2009, 23:36 GMT
Last edited by Jan de Groot (JGC) - Thursday, 23 April 2009, 19:22 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After recent kernel update module iwlagn doesn't load.


Additional info:
* kernel26 2.6.29.1-4

Steps to reproduce:

# modprobe iwlagn
FATAL: Error inserting iwlagn (/lib/modules/2.6.29-ARCH/kernel/drivers/net/wireless/iwlwifi/iwlagn.ko): Unknown symbol in module, or unknown parameter (see dmesg)

dmesg shows:

cfg80211: Unknown parameter `ieee80211_regdom'
mac80211: Unknown symbol regulatory_hint_11d
mac80211: Unknown symbol cfg80211_wext_giwname
mac80211: Unknown symbol cfg80211_wext_giwmode
mac80211: Unknown symbol wiphy_register
mac80211: Unknown symbol wiphy_new
mac80211: Unknown symbol wiphy_unregister
mac80211: Unknown symbol ieee80211_radiotap_iterator_init
mac80211: Unknown symbol __ieee80211_get_channel
mac80211: Unknown symbol cfg80211_wext_siwmode
mac80211: Unknown symbol ieee80211_radiotap_iterator_next
mac80211: Unknown symbol ieee80211_channel_to_frequency
mac80211: Unknown symbol ieee80211_frequency_to_channel
mac80211: Unknown symbol wiphy_free
iwlcore: Unknown symbol ieee80211_start_tx_ba_cb_irqsafe
iwlcore: Unknown symbol ieee80211_alloc_hw
iwlcore: Unknown symbol ieee80211_register_hw
iwlcore: Unknown symbol __ieee80211_get_radio_led_name
iwlcore: Unknown symbol ieee80211_wake_queue
iwlcore: Unknown symbol ieee80211_get_tkip_key
iwlcore: Unknown symbol __ieee80211_get_tx_led_name
iwlcore: Unknown symbol ieee80211_find_sta
iwlcore: Unknown symbol ieee80211_tx_status_irqsafe
iwlcore: Unknown symbol __ieee80211_get_rx_led_name
iwlcore: Unknown symbol ieee80211_stop_tx_ba_cb_irqsafe
iwlcore: Unknown symbol ieee80211_stop_queue
iwlcore: Unknown symbol ieee80211_stop_queues
iwlcore: Unknown symbol __ieee80211_get_assoc_led_name
iwlcore: Unknown symbol ieee80211_scan_completed
iwlcore: Unknown symbol ieee80211_channel_to_frequency
iwlcore: Unknown symbol ieee80211_hdrlen
iwlcore: Unknown symbol ieee80211_frequency_to_channel
iwlcore: Unknown symbol ieee80211_rx_irqsafe
iwlagn: Unknown symbol iwl_rxon_add_station
iwlagn: Unknown symbol iwl_scan_cancel_timeout
iwlagn: Unknown symbol iwl_rfkill_set_hw_state
iwlagn: Unknown symbol iwl_send_statistics_request
iwlagn: Unknown symbol iwl_set_default_wep_key
iwlagn: Unknown symbol iwl_scan_cancel
iwlagn: Unknown symbol iwl_rates
iwlagn: Unknown symbol iwl_chain_noise_calibration
iwlagn: Unknown symbol iwl_setup_spectrum_handlers
iwlagn: Unknown symbol ieee80211_free_hw
iwlagn: Unknown symbol iwl_remove_dynamic_key
iwlagn: Unknown symbol iwl_get_ra_sta_id
iwlagn: Unknown symbol iwl_rx_reply_compressed_ba
iwlagn: Unknown symbol iwl_txq_update_write_ptr
iwlagn: Unknown symbol iwl_rfkill_init
iwlagn: Unknown symbol iwl_eeprom_free
iwlagn: Unknown symbol iwl_set_rxon_channel
iwlagn: Unknown symbol ieee80211_start_tx_ba_session
iwlagn: Unknown symbol iwl_calib_set
iwlagn: Unknown symbol iwl_sta_tx_modify_enable_tid
iwlagn: Unknown symbol iwl_power_update_mode
iwlagn: Unknown symbol iwlcore_eeprom_release_semaphore
iwlagn: Unknown symbol iwl_hw_txq_ctx_free
iwlagn: Unknown symbol iwl_power_cancel_timeout
iwlagn: Unknown symbol iwl_bcast_addr
iwlagn: Unknown symbol iwl_eeprom_init
iwlagn: Unknown symbol iwl_add_station_flags
iwlagn: Unknown symbol ieee80211_rate_control_unregister
iwlagn: Unknown symbol iwl_radio_kill_sw_disable_radio
iwlagn: Unknown symbol iwl_set_rxon_ht
iwlagn: Unknown symbol ieee80211_wake_queue
iwlagn: Unknown symbol ieee80211_find_sta
iwlagn: Unknown symbol iwl_txq_ctx_stop
iwlagn: Unknown symbol iwl_enable_interrupts
iwlagn: Unknown symbol iwlcore_eeprom_acquire_semaphore
iwlagn: Unknown symbol iwl_init_drv
iwlagn: Unknown symbol iwl_tx_cmd_complete
iwlagn: Unknown symbol iwl_rx_reply_rx_phy
iwlagn: Unknown symbol iwl_setup_rx_scan_handlers
iwlagn: Unknown symbol iwl_send_cmd_pdu
iwlagn: Unknown symbol iwl_init_sensitivity
iwlagn: Unknown symbol iwl_rx_reply_rx
iwlagn: Unknown symbol iwl_reset_run_time_calib
iwlagn: Unknown symbol iwl_send_static_wepkey_cmd
iwlagn: Unknown symbol iwl_power_disable_management
iwlagn: Unknown symbol iwl_clear_stations_table
iwlagn: Unknown symbol iwl_radio_kill_sw_enable_radio
iwlagn: Unknown symbol iwl_uninit_drv
iwlagn: Unknown symbol iwl_rx_missed_beacon_notif
iwlagn: Unknown symbol iwl_eeprom_get_mac
iwlagn: Unknown symbol iwl_send_lq_cmd
iwlagn: Unknown symbol iwl_rf_kill_ct_config
iwlagn: Unknown symbol iwl_sta_rx_agg_start
iwlagn: Unknown symbol iwl_eeprom_query16
iwlagn: Unknown symbol iwl_rx_queue_space
iwlagn: Unknown symbol iwlcore_eeprom_query_addr
iwlagn: Unknown symbol get_cmd_string
iwlagn: Unknown symbol iwl_sensitivity_calibration
iwlagn: Unknown symbol ieee80211_wake_queues
iwlagn: Unknown symbol iwl_send_calib_results
iwlagn: Unknown symbol iwl_rx_queue_free
iwlagn: Unknown symbol ieee80211_rate_control_register
iwlagn: Unknown symbol iwl_verify_ucode
iwlagn: Unknown symbol iwl_set_tx_power
iwlagn: Unknown symbol iwl_rx_statistics
iwlagn: Unknown symbol iwl_setup_mac
iwlagn: Unknown symbol iwl_update_tkip_key
iwlagn: Unknown symbol iwl_send_cmd
iwlagn: Unknown symbol iwl_tx_skb
iwlagn: Unknown symbol iwl_power_enable_management
iwlagn: Unknown symbol iwl_tx_agg_start
iwlagn: Unknown symbol ieee80211_stop_queues
iwlagn: Unknown symbol iwl_tx_queue_reclaim
iwlagn: Unknown symbol iwl_disable_interrupts
iwlagn: Unknown symbol iwl_eeprom_check_version
iwlagn: Unknown symbol iwl_get_channel_info
iwlagn: Unknown symbol iwl_set_hw_params
iwlagn: Unknown symbol iwl_rx_replenish
iwlagn: Unknown symbol iwl_setup_scan_deferred_work
iwlagn: Unknown symbol iwl_hw_nic_init
iwlagn: Unknown symbol iwl_hw_detect
iwlagn: Unknown symbol iwl_alloc_all
iwlagn: Unknown symbol ieee80211_unregister_hw
iwlagn: Unknown symbol iwl_power_initialize
iwlagn: Unknown symbol iwl_sta_rx_agg_stop
iwlagn: Unknown symbol iwl_hwrate_to_plcp_idx
iwlagn: Unknown symbol iwl_hwrate_to_tx_control
iwlagn: Unknown symbol iwl_power_set_user_mode
iwlagn: Unknown symbol iwl_leds_register
iwlagn: Unknown symbol iwl_remove_default_wep_key
iwlagn: Unknown symbol iwl_send_cmd_pdu_async
iwlagn: Unknown symbol iwl_rx_queue_restock
iwlagn: Unknown symbol iwl_rfkill_unregister
iwlagn: Unknown symbol iwl_eeprom_query_addr
iwlagn: Unknown symbol iwl_leds_unregister
iwlagn: Unknown symbol ieee80211_beacon_get
iwlagn: Unknown symbol iwl_setup_power_deferred_work
iwlagn: Unknown symbol iwl_find_station
iwlagn: Unknown symbol iwl_set_dynamic_key
iwlagn: Unknown symbol iwl_scan_initiate
iwlagn: Unknown symbol ieee80211_frequency_to_channel
iwlagn: Unknown symbol iwl_txq_check_empty
iwlagn: Unknown symbol iwl_reset_qos
iwlagn: Unknown symbol iwl_rx_queue_update_write_ptr
iwlagn: Unknown symbol iwl_tx_agg_stop
iwlagn: Unknown symbol iwl_queue_space
iwlagn: Unknown symbol iwl_set_rxon_chain
iwlagn: Unknown symbol iwlcore_eeprom_verify_signature
iwlagn: Unknown symbol iwl_rxq_stop

This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 23 April 2009, 19:22 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Remove the invalid option from modprobe.conf and everything should work fine.
Comment by Jan de Groot (JGC) - Thursday, 23 April 2009, 05:50 GMT
Try running depmod -a, it should resolve the symbols. Rebooting into the new kernel would help also I think.
Comment by Krzemin (krzemin) - Thursday, 23 April 2009, 09:25 GMT
Didn't help. The module must be broken.
Comment by Jan de Groot (JGC) - Thursday, 23 April 2009, 09:38 GMT
works fine here:
cfg80211: Calling CRDA to update world regulatory domain
iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27ks
iwlagn: Copyright(c) 2003-2008 Intel Corporation

I think you have a different version of iwlcore loaded or installed. Could you do modinfo iwlcore?
Comment by Krzemin (krzemin) - Thursday, 23 April 2009, 18:08 GMT
Sure:

$ modinfo iwlcore
filename: /lib/modules/2.6.29-ARCH/kernel/drivers/net/wireless/iwlwifi/iwlcore.ko
license: GPL
author: Copyright(c) 2003-2008 Intel Corporation <ilw@linux.intel.com>
version: 1.3.27k
description: iwl core
srcversion: A59E5DCE9EC309B774C3065
depends: mac80211,led-class,cfg80211,rfkill
vermagic: 2.6.29-ARCH SMP preempt mod_unload

$ modinfo cfg80211
filename: /lib/modules/2.6.29-ARCH/kernel/net/wireless/cfg80211.ko
description: wireless configuration support
license: GPL
author: Johannes Berg
depends:
vermagic: 2.6.29-ARCH SMP preempt mod_unload


$ modinfo iwlagn
filename: /lib/modules/2.6.29-ARCH/kernel/drivers/net/wireless/iwlwifi/iwlagn.ko
alias: iwl4965
license: GPL
author: Copyright(c) 2003-2008 Intel Corporation <ilw@linux.intel.com>
version: 1.3.27ks
description: Intel(R) Wireless WiFi Link AGN driver for Linux
firmware: iwlwifi-4965-2.ucode
firmware: iwlwifi-5150-1.ucode
firmware: iwlwifi-5000-1.ucode
srcversion: 83982F1B1AADD8B47F84B41
alias: pci:v00008086d0000423Dsv*sd*bc*sc*i*
alias: pci:v00008086d0000423Csv*sd*bc*sc*i*
alias: pci:v00008086d0000423Bsv*sd00001011bc*sc*i*
alias: pci:v00008086d0000423Asv*sd00001021bc*sc*i*
alias: pci:v00008086d0000423Asv*sd00001001bc*sc*i*
alias: pci:v00008086d00004237sv*sd*bc*sc*i*
alias: pci:v00008086d00004236sv*sd*bc*sc*i*
alias: pci:v00008086d00004235sv*sd*bc*sc*i*
alias: pci:v00008086d00004232sv*sd*bc*sc*i*
alias: pci:v00008086d00004237sv*sd00001216bc*sc*i*
alias: pci:v00008086d00004232sv*sd00001326bc*sc*i*
alias: pci:v00008086d00004232sv*sd00001306bc*sc*i*
alias: pci:v00008086d00004232sv*sd00001206bc*sc*i*
alias: pci:v00008086d00004232sv*sd00001305bc*sc*i*
alias: pci:v00008086d00004232sv*sd00001205bc*sc*i*
alias: pci:v00008086d00004230sv*sd*bc*sc*i*
alias: pci:v00008086d00004229sv*sd*bc*sc*i*
depends: iwlcore,cfg80211,mac80211
vermagic: 2.6.29-ARCH SMP preempt mod_unload
parm: disable50:manually disable the 50XX radio (default 0 [radio on]) (int)
parm: swcrypto50:using software crypto engine (default 0 [hardware])
(bool)
parm: debug50:50XX debug output mask (uint)
parm: queues_num50:number of hw queues in 50xx series (int)
parm: 11n_disable50:disable 50XX 11n functionality (int)
parm: amsdu_size_8K50:enable 8K amsdu size in 50XX series (int)
parm: fw_restart50:restart firmware in case of error (int)
parm: antenna:select antenna (1=Main, 2=Aux, default 0 [both]) (int)
parm: disable:manually disable the radio (default 0 [radio on]) (int)
parm: swcrypto:using crypto in software (default 0 [hardware]) (int)
parm: debug:debug output mask (uint)
parm: disable_hw_scan:disable hardware scanning (default 0) (int)
parm: queues_num:number of hw queues. (int)
parm: 11n_disable:disable 11n functionality (int)
parm: amsdu_size_8K:enable 8K amsdu size (int)
parm: fw_restart4965:restart firmware in case of error (int)
Comment by Jan de Groot (JGC) - Thursday, 23 April 2009, 18:15 GMT
hmm, you don't happen to have a different version of these things loaded? The modinfo output looks fine to me.
Comment by Krzemin (krzemin) - Thursday, 23 April 2009, 18:32 GMT
For me too. That's why I'm posting the bug.

The module doesn't even load, so I think that's broken and someone should fix it.

I didn't installed any newer versions of iwl* drivers, only used these from kernel package, but if this helps someone...

$ ls /lib/modules/2.6.29-ARCH/kernel/net/wireless/* | xargs md5sum
451155454061e4dcd1fe86b54adebbc7 /lib/modules/2.6.29-ARCH/kernel/net/wireless/cfg80211.ko
ecc4a803a1e910c32d446d5e41c8b0d9 /lib/modules/2.6.29-ARCH/kernel/net/wireless/lib80211.ko
5341765f326bda90a9d7859bc8a35d0d /lib/modules/2.6.29-ARCH/kernel/net/wireless/lib80211_crypt_ccmp.ko
0520828cd04ab63f059f45c9eea7ee11 /lib/modules/2.6.29-ARCH/kernel/net/wireless/lib80211_crypt_tkip.ko
393fad6f1580deb55871f6084d402ac8 /lib/modules/2.6.29-ARCH/kernel/net/wireless/lib80211_crypt_wep.ko

$ ls /lib/modules/2.6.29-ARCH/kernel/drivers/net/wireless/iwlwifi/* | xargs md5sum
dc90c91be34272c6cb9e035347ec2486 /lib/modules/2.6.29-ARCH/kernel/drivers/net/wireless/iwlwifi/iwl3945.ko
eb8b229b44464aba07fcbf5a70d52a5a /lib/modules/2.6.29-ARCH/kernel/drivers/net/wireless/iwlwifi/iwlagn.ko
f92242f1f4ca7c2031622f97117d4264 /lib/modules/2.6.29-ARCH/kernel/drivers/net/wireless/iwlwifi/iwlcore.ko
Comment by Jan de Groot (JGC) - Thursday, 23 April 2009, 19:15 GMT
hmm, wait a minute... this is a configuration error on your side:

cfg80211: Unknown parameter `ieee80211_regdom'

because of that in /etc/modprobe.conf, the cfg80211 module won't load and other modules can't resolve the required symbols. You need crda to set your wireless regdomain.

Loading...