Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14395 - pidgin hangs after last package upgrade

Attached to Project: Arch Linux
Opened by Giorgio (uastasi) - Monday, 20 April 2009, 09:06 GMT
Last edited by Jan de Groot (JGC) - Monday, 20 April 2009, 20:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
pidgin hangs on password prompt, and it can be only killed from bash.
I have noticed that startup-notification is a pidgin dependency: since it's been upgraded yesterday from 0.9-1 to 0.10-1 it could be the culprit.

Additional info:
* package version(s)
pidgin 2.5.5-2
startup-notification 0.10-1

* config and/or log files etc.
/var/log/pacman.log
[2009-04-20 00:21] starting full system upgrade
[2009-04-20 00:22] upgraded poppler (0.10.5-1 -> 0.10.6-1)
[2009-04-20 00:22] upgraded poppler-glib (0.10.5-1 -> 0.10.6-1)
[2009-04-20 00:23] upgraded evince (2.26.0-1 -> 2.26.1-1)
[2009-04-20 00:23] upgraded libsoup (2.26.0-1 -> 2.26.1-1)
[2009-04-20 00:23] upgraded libgweather (2.26.0-1 -> 2.26.1-1)
[2009-04-20 00:23] upgraded evolution-data-server (2.26.0-1 -> 2.26.1.1-1)
[2009-04-20 00:23] upgraded gtkhtml (3.26.0-1 -> 3.26.1.1-1)
[2009-04-20 00:23] upgraded evolution (2.26.0-1 -> 2.26.1.1-1)
[2009-04-20 00:23] upgraded evolution-exchange (2.26.0-2 -> 2.26.1-1)
[2009-04-20 00:24] upgraded file-roller (2.26.0-1 -> 2.26.1-1)
[2009-04-20 00:24] upgraded xcb-util (0.3.3-1 -> 0.3.4-1)
[2009-04-20 00:24] upgraded startup-notification (0.9-1 -> 0.10-1)
[2009-04-20 00:24] upgraded gnome-desktop (2.26.0-1 -> 2.26.1-1)
[2009-04-20 00:24] upgraded gnome-doc-utils (0.16.0-1 -> 0.16.1-1)
[2009-04-20 00:24] upgraded gnome-menus (2.26.0-1 -> 2.26.1-1)
[2009-04-20 00:24] upgraded libwnck (2.26.0-1 -> 2.26.1-1)
[2009-04-20 00:24] upgraded gnome-panel (2.26.0-1 -> 2.26.1-1)
[2009-04-20 00:24] upgraded gnome-settings-daemon (2.26.0-1 -> 2.26.1-1)
[2009-04-20 00:24] upgraded gnome-themes (2.26.0-1 -> 2.26.1-1)
[2009-04-20 00:24] upgraded libxklavier (3.9-1 -> 3.9-2)
[2009-04-20 00:24] upgraded meld (1.3.0-1 -> 1.3.0-2)
[2009-04-20 00:24] upgraded nautilus-sendto (1.1.3-1 -> 1.1.4-1)
[2009-04-20 00:24] upgraded pango (1.24.0-2 -> 1.24.1-1)


Steps to reproduce:
1. open pidgin
2. try to connect to an account
   pidgin-bug (404.6 KiB)
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 20 April 2009, 20:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with nautilus-sendto 1.1.4.1.
Comment by Mathieu Clabaut (mathieu.clabaut) - Monday, 20 April 2009, 17:28 GMT
Same thing here.
Comment by Szathmari Gabor (gszathmari) - Monday, 20 April 2009, 18:24 GMT
Same with 100% CPU usage
Comment by Alessandro (alka) - Monday, 20 April 2009, 19:45 GMT
i have narrowed the bug down to the update of the package nautilus-sendto
with gdb i have found that the function take_spool_files from /usr/lib/pidgin/nautilus.so loops
Comment by Jozef Mares (kain) - Monday, 20 April 2009, 20:22 GMT
confirmation there. same symptoms like 100% cpu, hang. after uninstall nautilus-sendto package everythings works just like charm.

Loading...