Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14394 - xf86-video-intel 2.7.0 tiling issue

Attached to Project: Arch Linux
Opened by Matthew William Cox (mwc) - Monday, 20 April 2009, 06:50 GMT
Last edited by Jan de Groot (JGC) - Saturday, 09 May 2009, 23:16 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

Version 2.7.0-1 of the package has display corruption issues on (at least) the X4500 GPU. The issue is that the kernel side of things is missing functionality, and requires a patch http://git.kernel.org/?p=linux/kernel/git/anholt/drm-intel.git;a=commit;h=f544847fbaf099278343f875987a983f2b913134 to set things right. This patch is posted on the freedesktop.org bugtracker.

I'm building a kernel right now and will report back to confirm this fixes the bug.

Additional info:
This bug on the arch forum: http://bbs.archlinux.org/viewtopic.php?id=70209
This bug on the freedesktop.org bugtracker: http://bugs.freedesktop.org/show_bug.cgi?id=21246
This task depends upon

Closed by  Jan de Groot (JGC)
Saturday, 09 May 2009, 23:16 GMT
Reason for closing:  Fixed
Comment by Matthew William Cox (mwc) - Monday, 20 April 2009, 07:29 GMT
Hello again,

built 2.6.29.1-4 including the above patch. Tiling works again!
Comment by Matthew William Cox (mwc) - Thursday, 30 April 2009, 17:04 GMT
Bug persists in 2.6.29.2-1. Rebuilding this package with the aforementioned patch again fixes the issue.
Comment by Alberto Gonzalez (Luis) - Saturday, 09 May 2009, 17:03 GMT
This issue is fixed with kernel26-2.6.29.3-1.

Loading...