Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14318 - [flightgear] crashes with mesa 7.4

Attached to Project: Community Packages
Opened by Pawel (kraftman) - Friday, 17 April 2009, 10:47 GMT
Last edited by Sergej Pupykin (sergej) - Monday, 08 June 2009, 14:30 GMT
Task Type Bug Report
Category
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Hi,

I am using open source radeon driver (Ati X1600xt card, x86-64) and I have this error when I want to run Flight Gear:

$fgfs

Model Author: Unknown
Creation Date: 2002-01-01
Version: $Id: c172p.xml,v 1.20 2008/09/01 15:14:33 torsten Exp $
Description: Cessna C-172
FGMultiplayMgr - No receiver port, Multiplayermode disabled
KI266 dme indicator #0 initialized
Initializing Nasal Electrical System
*********************************WARN_ONCE*********************************
File r300_state.c function r500SetupRSUnit line 1907
Don't know how to satisfy InputsRead=0x00000008
***************************************************************************
fgfs: r300_texstate.c:348: r300SetTexImages: Assertion `numLevels <= 12' failed.

Packages:

mesa 7.4-1
xf86-video-ati 6.12.2-1
xorg-server 1.6.1-1
flightgear 1.9.1-2

Steps to reproduce:

Just run fgfs on system with open source radeon driver (r500 card and probably on similar).

Following to this:

https://bugzilla.redhat.com/show_bug.cgi?id=467907

bug should be already fixed. Workaround mentioned there works - export LIBGL_ALWAYS_SOFTWARE="yes" but games is terribly slow then.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Monday, 08 June 2009, 14:30 GMT
Reason for closing:  Not a bug
Additional comments about closing:  mesa bug
Comment by Pawel (kraftman) - Thursday, 30 April 2009, 10:43 GMT
Still present in mesa 7.4.1-1...
Comment by Pawel (kraftman) - Saturday, 16 May 2009, 08:24 GMT
The same with 7.4.2-1, but who cares?
Comment by Sergej Pupykin (sergej) - Wednesday, 03 June 2009, 17:08 GMT
I do not see any patches in fedora package: FlightGear-1.9.1-3.fc11.src.rpm

Is it fixed in mainstream?
Comment by Pawel (kraftman) - Thursday, 04 June 2009, 11:35 GMT
Hi,

According to https://bugzilla.redhat.com/show_bug.cgi?id=467907#c11

patch/patches should be in some of those packages:

glx-utils-7.2-0.15.fc10.i386.rpm
mesa-debuginfo-7.2-0.15.fc10.i386.rpm
mesa-demos-7.2-0.15.fc10.i386.rpm
mesa-dri-drivers-7.2-0.15.fc10.i386.rpm
mesa-libGL-7.2-0.15.fc10.i386.rpm
mesa-libGL-devel-7.2-0.15.fc10.i386.rpm
mesa-libGLU-7.2-0.15.fc10.i386.rpm
mesa-libGLU-devel-7.2-0.15.fc10.i386.rpm
mesa-libOSMesa-7.2-0.15.fc10.i386.rpm
mesa-libOSMesa-devel-7.2-0.15.fc10.i386.rpm

However, mesa 7.5 should arrive soon (wishful thinking ;)) and maybe this bug will be fixed there. Thanks.
Comment by Sergej Pupykin (sergej) - Thursday, 04 June 2009, 12:08 GMT
In this case this bug should be reassigned. I can not maintain mesa packages because of they are in [extra]
Comment by Pawel (kraftman) - Friday, 05 June 2009, 13:28 GMT
Yeah, my fault. Can you delete this report, please?

Loading...