FS#14246 - [kernel26] [alsa] 2.6.29 breaks snd-hda-intel at least for ALC1200

Attached to Project: Arch Linux
Opened by Ralf Barth (Haggy) - Tuesday, 14 April 2009, 21:19 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 16 June 2009, 08:16 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 15
Private No


regression in ALSA 1.0.19 causing broken spdif out on ALC1200. the forums are full
of threads with users complaining broken or lost audio with all sorts of soundcards
after upgrading to 2.6.29.

Additional info:
- x86_64, kernel 2.6.29, alsa 1.0.19
- everything worked in 2.6.28 and i did not change a single line
- no failure messages, no logged errors, just as if speakers are not plugged in, but yes:
they are definitely

Steps to reproduce:
- install kernel 2.6.29 on a machine with ALC1200 (ASUS M3N78-EM f.e.)
- try to output via iec958 (with speaker-test f.e.)
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 16 June 2009, 08:16 GMT
Reason for closing:  Fixed
Comment by Ralf Barth (Haggy) - Tuesday, 14 April 2009, 22:35 GMT
After compiling and installing alsa-driver 1.0.18a from source i can narrow this down to alsa-driver version 1.0.19. which had seen some patches for hda-intel. Using 1.0.18a i have my sound back, but i consider this a nasty workaround.
Comment by John Gerritse (ReaphSharc) - Thursday, 16 April 2009, 06:07 GMT
I run i686, Intel Corporation 82801H (ICH8 Family) HD Audio Controller, ALSA and also lost all sound after a 2.6.29 kernel upgrade.
Comment by Johannes Krampf (wuischke) - Thursday, 16 April 2009, 06:39 GMT
I can confirm this bug. I use Arch i686 and have a Conexant CX20549 Venice using the snd-hda-intel driver.

Curiously, though, unloading and reloading the module brings sound back for me.
Comment by Krishnan (kgas) - Thursday, 16 April 2009, 14:24 GMT
I confirm this bug that alsa failed to function in Acer and Lenovo laptops (i686 installation). The card details are
Acer : Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02))
Lenovo :Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03))
It is strange that compiled alsa (from PKGBUILD) also did not work
Comment by Vinicius Moraes (vsmoraes) - Thursday, 16 April 2009, 19:37 GMT
I can confirm this bug too. Alsa stop working on my Toshiba laptop (Arch i686) with a Intel HDA sound card.
Comment by Krishnan (kgas) - Saturday, 18 April 2009, 13:52 GMT
some more information.
alsaconf did not detect the sound card in Acer laptop. lspci lists the hardware as mentioned.
alsa daemon fails to load (obivious as no sound card detected)
Comment by Frank (cinan) - Saturday, 18 April 2009, 14:14 GMT
Arch Linux i686
My audio device is: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
I have sound, everything work but I noticed that after upgrade to 2.6.29 alsamixer doesn't show option "mute" on Master and PCM. Also there's no Front channel.

Krishnan: I had same problem. Alsa daemon:
/usr/sbin/alsactl: load_state:1569: Cannot open /etc/asound.state for reading: No such file or directory
Unknown hardware: "HDA-Intel" "Realtek ID 662" "HDA:10ec0662,1458a002,00100101" "" ""
Hardware is initialized using a guess method
Unknown hardware: "HDA-Intel" "ATI ID aa01" "HDA:1002aa01,00aa0100,00100000" "" ""
Hardware is initialized using a guess method
Then I did "alsactl store" and now there's no problem with alsa daemon.
Comment by Krishnan (kgas) - Sunday, 19 April 2009, 15:02 GMT
Thanks Frank, it did not work in my case.One more interesting observation.I have arch installation on another disk also (For Lenovo two sata disks/Acer three PATA disks) one disk with LXDE and another with GNOME.In both laptops disk with GNOME works fine with alsa. But alsa in LXDE fails. (2.6.29-ARCH). For Acer laptop I have a third disk with 2.6.28 arch in which alsa works fine.Theoretically alsa should work with any DE. As I could not completely remove alsa-lib because of LXDE panel /vlc etc depends on it. I will do further trails and post the result here.
Comment by Ralf Barth (Haggy) - Monday, 20 April 2009, 08:25 GMT

options snd-hda-intel model=6stack-dig probe_mask=1

to /etc/modprobe.conf fixes digital out for for ALC1200
Comment by Anton Werner (Fargard) - Wednesday, 29 April 2009, 20:31 GMT
maybe, but i can confirm that also this doesn't help for me.
Card just crashes after startup
Comment by Krishnan (kgas) - Tuesday, 12 May 2009, 17:23 GMT
after the recent system update on 10.05.09, alsa started working fine.
Comment by Tobias Powalowski (tpowa) - Wednesday, 13 May 2009, 05:48 GMT
anyone else can confirm that it is fixed?
Comment by Thomas Bächler (brain0) - Wednesday, 13 May 2009, 07:58 GMT
This bug report is completely worthless, as there are at least three different problems (with similar symptoms) reported in the comments. We are dealing with three different bugs in one bug report, where one is apparently fixed.

For some of the above reports, it seems only some channels changed, so reconfiguring the alsa mixer will help. For others, drivers are actually broken.
Comment by Ralf Barth (Haggy) - Wednesday, 13 May 2009, 08:30 GMT
Thomas, i'm sorry that this bug got hijacked with different issues. As for my (original) issue - yes it got fixed with this the lines in modprobe.conf i posted some comments before (http://bugs.archlinux.org/task/14246#comment42956). Feel free to rename/close/duplicate this bug for any further steps.