Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14236 - JRE requires libXtst to run, but it's not a dependency

Attached to Project: Community Packages
Opened by Lars Stokholm (stokholm) - Tuesday, 14 April 2009, 16:24 GMT
Last edited by Ionut Biru (wonder) - Wednesday, 22 April 2009, 15:53 GMT
Task Type Bug Report
Category
Status Closed
Assigned To Geoffroy Carrier (gcarrier)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since the recent update of X.org (1.6.0), xorg-utils is no longer depended upon by packages essential to running an X session. Therefore xorg-utils can be uninstalled. But xorg-utils depends on libXtst which, if uninstalled, will render JRE useless. So JRE should depend on libXtst.

Additional info:
[lars@laptop ~]$ pacman -Q jre libxtst
jre 6u12-1
libxtst 1.0.3-1
[lars@laptop ~]$ pacman -Qi libxtst | grep "Required By"
Required By : None

Steps to reproduce:
1) pacman -Rns xorg-utils (make sure libXtst is removed)
2) Go to http://www.java.com/en/download/help/testvm.xml
This task depends upon

Closed by  Ionut Biru (wonder)
Wednesday, 22 April 2009, 15:53 GMT
Reason for closing:  Fixed

Loading...