FS#14218 - [metacity] Gnome task bar - problems with maximizing programs from other desktops

Attached to Project: Arch Linux
Opened by Markus (xor_eax_eax) - Monday, 13 April 2009, 16:55 GMT
Last edited by Roman Kyrylych (Romashka) - Monday, 15 November 2010, 19:13 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Low
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



There are problems with maximizing minimized programs since Gnome 2.26. When a program is minimized, I switch to another (maximized) program on another desktop and want to switch back to the first program, it neither gets the focus nor is it maximized. You have to switch back to the desktop where the program runs to regain control on it.
I tested it with Streamtuner and Firefox

Additional info:
Gnome desktop 2.26-0.1
streamtuner 0.99.99-10
Firefox 3.0.8-1

Steps to reproduce:
Open streamtuner on desktop 1 and minimize it
Switch to desktop 2 and open Firefox (maximized)
Now you see the task of Firefox and Streamtuner in the taskbar. Streamtuner is in brackets like this [ streamtuner ] because it's minimized.
Usually when you want to switch back into streamtuner, you just had to click the [ streamtuner ] task. In gnome 2.26 when you click this task, the font of [ streamtuner ] becomes fat and begins to blink, but it neither gets the focus nor is it maximized.
You have to switch back to desktop 1 (where streamtuner runs). When you click the task in this desktop now, it is displayed maximized as usual.

While these tests Firefox suddendly looses the focus although it wasn't minimized. I had to minimize, to maximize, and to shift the programs from one desktop to another to regain control of Firefox.
Earliert tests led me to a behaviour, with which I wasn't able to regain control on Firefox. I had to close Firefox with the context menu and had to reopen it.
I don't know how to reproduce this behaviour yet, but it's basically one bug.

This task depends upon

Closed by  Roman Kyrylych (Romashka)
Monday, 15 November 2010, 19:13 GMT
Reason for closing:  Upstream
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 31 May 2009, 09:40 GMT
status with latest packages?
Comment by Jan de Groot (JGC) - Sunday, 31 May 2009, 09:52 GMT
I think I added a patch for this one on the latest metacity version. Someone reported this by using the out-of-date flag.
Comment by Markus (xor_eax_eax) - Sunday, 31 May 2009, 14:22 GMT
The problem still exists (gnome-desktop 2.26.2-1)

I have metacity version extra/metacity 2.26.0-2, but the problem does not seem to be solved with it.
Comment by Jan de Groot (JGC) - Tuesday, 20 October 2009, 12:52 GMT
Is this fixed with 2.28.0?
Comment by Markus (xor_eax_eax) - Thursday, 22 October 2009, 21:35 GMT
No, and I wonder when this annoying bug will finally be fixed.
Comment by Jan de Groot (JGC) - Thursday, 22 October 2009, 21:39 GMT
Did you file it upstream?
Comment by Markus (xor_eax_eax) - Friday, 23 October 2009, 13:47 GMT
What exactly do you mean. To raise the serverity?
Comment by Jan de Groot (JGC) - Friday, 23 October 2009, 13:58 GMT
To get things fixed. We're not the creators of metacity, we only package it. I can apply patches from bugzilla and/or git, I can fix common programming mistakes in software, but I can't change behaviour of a window manager.
Comment by Markus (xor_eax_eax) - Tuesday, 27 October 2009, 10:57 GMT
For me it seems to be a gnome problem, because switching to minimized applications from another surface doesn't work with any application. Before this updated in April it worked.
Comment by Ionut Biru (wonder) - Sunday, 03 January 2010, 19:47 GMT
@Markus if you really want this to be fixed please submit it on http://bugzilla.gnome.org
Comment by Markus (xor_eax_eax) - Tuesday, 26 January 2010, 07:46 GMT
The problem can be reproduced on Ubuntu too and has been reported to Gnome.
Comment by Jan de Groot (JGC) - Tuesday, 26 January 2010, 07:54 GMT
Do you have a link to GNOME bugzilla so I can track it?
Comment by Markus (xor_eax_eax) - Tuesday, 26 January 2010, 07:58 GMT Comment by Glenn Matthys (RedShift) - Monday, 15 November 2010, 11:16 GMT
What's the status of this issue?
Comment by Jan de Groot (JGC) - Monday, 15 November 2010, 11:19 GMT
Upstream has not commented on the bug, and no new releases have been made ever since, so the status is still the same. Don't expect this to get fixed anyways, as development focuses on Mutter instead.