Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14155 - [mplayer-plugin] Apple's trailers crashes browser

Attached to Project: Arch Linux
Opened by VuDu (VuDu) - Thursday, 09 April 2009, 14:13 GMT
Last edited by Jan de Groot (JGC) - Sunday, 01 November 2009, 15:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Opening a video on the Apple Trailers using mplayer-plugin causes the browser to instantly crash/shutdown.

Additional info:
* using mplayer-plugin 3.55-1 on x86_64 (can't confirm on i686)
* verified on Firefox, Epiphany and Midori
* Opera doesn't seem to crash but one can see the video pop-up window showing and vanishing almost instantaneously.
* last info from the browser:
[code]
ADDED URL: hannahmontanathemovie_h480p.mov
code: 31
speed -1
[/code]

Steps to reproduce:
Open an Apple Trailers page (for instance http://www.apple.com/trailers/disney/hannahmontanathemovie/hd/ xD) and click on a trailer link.

This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 01 November 2009, 15:22 GMT
Reason for closing:  Won't fix
Additional comments about closing:  Package has been removed from repository, please use gecko-mediaplayer.
Comment by Oliver Herold (oli) - Saturday, 16 May 2009, 11:22 GMT Comment by Oliver Herold (oli) - Saturday, 16 May 2009, 13:06 GMT
Btw. mplayerplug-in doesn't compile with gcc4.4, same problem as there: http://www.nabble.com/mplayerplugin-fails-to-compile-with-gcc4.3-td15443866.html
Comment by VuDu (VuDu) - Saturday, 16 May 2009, 18:49 GMT
Ok, when I opened this bug report I didn't know this, but on the sourceforge patch link we can read this from the project admin:

[quote]
>> Also, have you tried gecko-mediaplayer?
>
> I was not aware of it. I was rather happy with mplayerplug-in. Is it dead?
>
> Debian has gecko-mediaplayer 0.9.5-1 and it plays both trailers. Is
> there a way to cache the whole clip before playback? my connection is
> rather flaky when it comes to streaming video.
>
> Looks like it's time to switch...

Yes, mplayerplug-in is depreciated, I shutdown new development on it
about 24 months ago and all new effort has been on gecko-mediaplayer.

http://kdekorte.blogspot.com/2007/02/mplayerplug-in-being-changed-to-gecko.html

Kevin
[/quote]

So basically mplayer-plugin was deprecated, giving place to gecko-mediaplayer.

The question now might be if the arch mplayer-plugin maintainer should apply the patch or maybe one could convince the Kevin to release a last version with that patch applied.

Comment by Oliver Herold (oli) - Sunday, 17 May 2009, 17:33 GMT
Yeah, thx for the hint - gecko-mediaplayer works like a charme :-)

Loading...