Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14147 - [mpd] Fails to start after upgrade

Attached to Project: Arch Linux
Opened by Markus Martin (Archwyrm) - Thursday, 09 April 2009, 05:57 GMT
Last edited by Allan McRae (Allan) - Friday, 10 April 2009, 02:18 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
mpd fails to start after upgrading giving the message:

mpd: error while loading shared libraries: libfaad.so.1: cannot open shared object file: No such file or directory

A new version of faad2 was installed along with mpd. This version does not provide libfaad.so.1 but rather libfaad.so.2. Just needs a recompile.

Additional info:
* package version(s)
mpd 0.14.2-1
faad2 2.7-1

There was a thread regarding this issue in the testing forum:
http://bbs.archlinux.org/viewtopic.php?id=67973
This task depends upon

Closed by  Allan McRae (Allan)
Friday, 10 April 2009, 02:18 GMT
Reason for closing:  Works for me
Comment by Jan de Groot (JGC) - Thursday, 09 April 2009, 10:29 GMT
Can't reproduce on at least x86_64. Be sure to update everything, not just faad2 and mpd.
Comment by Allan McRae (Allan) - Thursday, 09 April 2009, 11:25 GMT
Can not replicate on i686 either.
Comment by Eric Belanger (Snowman) - Thursday, 09 April 2009, 18:55 GMT
Make sure that you are using the mpd from the repo, i.e. not a self compiled package.
Comment by Markus Martin (Archwyrm) - Friday, 10 April 2009, 01:45 GMT
> Be sure to update everything, not just faad2 and mpd.

I did this and mpd starts up just fine. Now ldd shows libfaad.so.2 instead of libfaad.so.1, yet the mpd binary has not changed, which I find a bit disturbing. Perhaps somehow related to glibc updating..?

Anyway, sorry for the noise. =/

Loading...