Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14124 - [namcap] should be able to handle interchangeable dependencies

Attached to Project: Arch Linux
Opened by Philipp (hollunder) - Monday, 06 April 2009, 14:07 GMT
Last edited by Rémy Oudompheng (remyoudompheng) - Friday, 18 February 2011, 22:37 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Dan McGee (toofishes)
Rémy Oudompheng (remyoudompheng)
Hugo Doria (hdoria)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Examples sere better than descriptions:

lash-git: provides=('lash=0.6.0')
calf-git: depends=('fluidsynth' 'libglade' 'lash>=0.6.0')

namcap calf-git-20090406-1-i686.pkg.tar.gz
calf-git E: Dependency detected and not included (lash-git) from
files ['usr/bin/calfjackhost']
calf-git W: Dependency included and not needed (lash)

There are many more packages that can use a number of different packages as dependencies, not just normal and git versions.
Namcap should be able to handle this using provides=() and depends=(), versioned as well as unversioned.


Additional info:
* package version(s)
namcap 2.2-2
* config and/or log files etc.
-

Steps to reproduce:
-
This task depends upon

Closed by  Rémy Oudompheng (remyoudompheng)
Friday, 18 February 2011, 22:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  in 2.8.1
Comment by Allan McRae (Allan) - Monday, 13 April 2009, 07:33 GMT
Seems related to  FS#7122 
Comment by Rémy Oudompheng (remyoudompheng) - Tuesday, 25 January 2011, 22:08 GMT
namcap already handles that, if I read correctlly. A problem subsisted in the treatment of versioned provides. This commit should fix the remaining issues, please test.
http://projects.archlinux.org/users/remy/namcap.git/commit/?id=d085c064c8a8544c7e198317aa8c10d5ba60b0f6

Loading...