Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14093 - Xorg causes 100% CPU load after updating to GNOME 2.26

Attached to Project: Arch Linux
Opened by ricsch (ricsch) - Saturday, 04 April 2009, 18:48 GMT
Last edited by Jan de Groot (JGC) - Sunday, 05 April 2009, 13:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:
After updating to GNOME 2.26 Xorg causes 100% CPU load. I couldn't determine a exact part of GNOME causing this. The problem also occurs when GNOME is used with default configuration under a new user account.

Package versions:
GNOME 2.26
X.Org X Server 1.5.3
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 05 April 2009, 13:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  Please update to xorg-server 1.5.3-5 from extra, or xorg-server-1.6.0 from testing.
Comment by Steffen Weber (boenki) - Saturday, 04 April 2009, 19:27 GMT
I just want to confirm this problem.
video-driver is nvidia

Comment by ricsch (ricsch) - Saturday, 04 April 2009, 19:33 GMT
The problems seems to be independent of the used video driver. It makes no difference wheter I use nvidia or nv. In the BBS I also read that a intel user is affected.
Comment by Ionut Biru (wonder) - Saturday, 04 April 2009, 19:44 GMT
try to update xorg to testing
Comment by ricsch (ricsch) - Saturday, 04 April 2009, 20:05 GMT
Updating to X.Org X Server 1.6.0 is a possible workarround.
Comment by Mathias Burén (fackamato) - Saturday, 04 April 2009, 21:15 GMT
I can confirm this bug, it exists regardless of which video driver is being used. It also appears with a clean config (I created a new user 'test' which experienced the same 100% CPU bug).

I can confirm that upgrading to X.Org X Server 1.6.0 fixes the bug.
Comment by ricsch (ricsch) - Saturday, 04 April 2009, 21:18 GMT
In #archlinux I heard that downgrading gnome-session should fix the problem also.
Comment by abv (alebetco) - Saturday, 04 April 2009, 21:44 GMT
i can confirm this bug
Comment by Jan de Groot (JGC) - Saturday, 04 April 2009, 22:53 GMT
I've tracked it down to this commit in gnome-session:
http://svn.gnome.org/viewvc/gnome-session?view=revision&revision=5210
Comment by Jan de Groot (JGC) - Saturday, 04 April 2009, 23:25 GMT Comment by João Vieira (Vieira) - Sunday, 05 April 2009, 00:10 GMT
Same problem here. Waiting for 1.6 to hit the core repository...
Comment by Ricardo Rodrigues (Ricksa) - Sunday, 05 April 2009, 00:30 GMT
Same problem here, after upgrading to gnome 2.26 my laptop melted into to a little puddle of plastic.
Comment by Lyman Li (lyman) - Sunday, 05 April 2009, 06:21 GMT
+1
Comment by Börje Holmberg (linfan) - Sunday, 05 April 2009, 07:35 GMT
I have the same issue. Downgrading gnome-session and adding it to IgnorePkg in /etc/pacman.conf fixes the problem.

Here is some more to read about it: http://support.zenwalk.org/viewtopic.php?f=36&t=21775
Comment by Styx (Styx) - Sunday, 05 April 2009, 10:53 GMT
I got the same problem after GNOME upgrade to the newest version.
I've downgraded gnome-session :

# wget http://ftp.icm.edu.pl/pub/Linux/sunsite/distributions/archlinux/extra/os/i686/gnome-session-2.24.3-1-i686.pkg.tar.gz
# pacman -U gnome-session-2.24.3-1-i686.pkg.tar.gz

And of course I've added gnome-session to IgnorePkg in /etc/pacman.conf such the previous comment.

Loading...