Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14085 - [squid] should be compiled with --enable-epoll

Attached to Project: Arch Linux
Opened by Lee.MaRS (leemars) - Friday, 03 April 2009, 19:38 GMT
Last edited by Dan McGee (toofishes) - Sunday, 13 September 2009, 13:53 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Kevin Piche (kpiche)
Hugo Doria (hdoria)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
The epoll support was merge into squid 2.6 long time ago. It makes squid to use less cpu, from 50%+ to 10% in my P4 1.7G/384M proxy server. So I think it's a big performance problem.

In PKGBUILD, squid was compiled with --enable-poll, which force it to use poll.

I think --enable-poll should be removed, or replaced with --enable-epoll.
This task depends upon

Closed by  Dan McGee (toofishes)
Sunday, 13 September 2009, 13:53 GMT
Reason for closing:  Implemented
Additional comments about closing:  squid-2.7.STABLE6-3

Loading...