Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#1407 - gthumb: not compiled against libexif or libgphoto2

Attached to Project: Arch Linux
Opened by Link Dupont (link) - Friday, 10 September 2004, 08:00 GMT
Last edited by Dale Blount (dale) - Friday, 10 September 2004, 12:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To arjan timmerman (blaasvis)
Architecture not specified
Severity Very Low
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

The package gthumb-2.4.1-2 is not linked against libexif or libgphoto2. I feel gthumb should link against both. EXIF data is useful whether or not you use a digital camera, and it seems weird to me that an image viewer application would not link against libexif. And in order to use gthumb's "Import photos" option, it needs to link against libgphoto2. Again, another useful feature for an image viewing application.
This task depends upon

Closed by  arjan timmerman (blaasvis)
Saturday, 18 September 2004, 08:12 GMT
Reason for closing:  Not a bug
Comment by arjan timmerman (blaasvis) - Friday, 10 September 2004, 13:59 GMT
there is an reason for not linking against libexif, it will make gthumb crash. if a new version will arise i will add it again.

and for libgphoto2 no i will not add it, it is against the "kiss" priciple if you want it build it yourself with abs.
it is not an neccassery feature for gthumb to run. and not all people have an camera ;)

if leave this open for discussion for a while if most users think it is needed i might add it.
Comment by Link Dupont (link) - Friday, 10 September 2004, 14:09 GMT
In what scenario does libexif crash gthumb? I've (obviously) already rebuilt it in abs, so its now linked against libexif, and I've not experienced any crashes so far.
Comment by arjan timmerman (blaasvis) - Saturday, 11 September 2004, 11:34 GMT
http://bugs.archlinux.org/index.php?do=details&id=1070

it made nautilus/gthumb crash on some jpeg's
Comment by Link Dupont (link) - Monday, 13 September 2004, 03:25 GMT
Hmm, well, I've not tried nautilus, but my gthumb build does not seem to have any problems compiling. Oh well. Feel free to close this I suppose. I'll just roll my own gthumb pkgs.
Comment by arjan timmerman (blaasvis) - Monday, 13 September 2004, 05:55 GMT
it isn't the compiling of the program the causes problems, it is running it ;)
Comment by Link Dupont (link) - Monday, 13 September 2004, 13:16 GMT
Right, and I've not seen gthumb crash yet. Maybe its not libexif's fault, but incorrectly generated EXIF data on the file?
Comment by arjan timmerman (blaasvis) - Saturday, 18 September 2004, 08:12 GMT
ah well i will build the next gthumb release again libexif again, closing this one.

Loading...