Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#14030 - kcachegrind: symbol lookup error: /usr/lib/libkdecore.so.5: undefined symbol: qt_locale_initialized

Attached to Project: Arch Linux
Opened by Dieter Plaetinck (Dieter_be) - Monday, 30 March 2009, 15:32 GMT
Last edited by Pierre Schmitz (Pierre) - Monday, 30 March 2009, 19:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have a non-kde system (wmii, some gtk apps), on which I want to use kcachegrind.

So I did: "pacman -Sy kdesdk"

Targets (15): libxvmc-1.0.4-1 esound-0.2.41-1 xine-lib-1.1.16.2-1 phonon-4.3.1-1 clucene-0.9.21b-1 exiv2-0.17.1-1 strigi-0.6.4-1 soprano-2.2.3-1 kdelibs-4.2.1-3 rarian-0.8.1-1 kdebase-runtime-4.2.1-1
akonadi-1.1.1-1 libical-0.43-1 kdepimlibs-4.2.1-1 kdesdk-4.2.1-1


All packages install fine, no messages about optdeps I need
(Note I'm not using testing. I only use core/community/extra)

When I want to run kcachegrind, I get this:
[dieter@dieter-dellD620-arch ~]$ kcachegrind
kcachegrind: symbol lookup error: /usr/lib/libkdecore.so.5: undefined symbol: qt_locale_initialized
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Monday, 30 March 2009, 19:10 GMT
Reason for closing:  Not a bug
Comment by Dieter Plaetinck (Dieter_be) - Monday, 30 March 2009, 16:51 GMT
after upgrading the complete system the error disappears and kcachegrind works.
So I guess you're not depending on the correct version somewhere.
Comment by Pierre Schmitz (Pierre) - Monday, 30 March 2009, 18:19 GMT
Well, usually we don't have such strict versioned dependencies. Installing packages on an outdated system is just not supported. :-)
Comment by Dieter Plaetinck (Dieter_be) - Monday, 30 March 2009, 18:34 GMT
I can live with that. :)

Loading...