Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#1399 - gcc 3.4.2 causes trouble

Attached to Project: Arch Linux
Opened by Tobias Powalowski (tpowa) - Wednesday, 08 September 2004, 08:21 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To Judd Vinet (judd)
Architecture not specified
Severity High
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

the new gcc version causes trouble with fam, qtparted
/usr/bin/fam: /usr/lib/libstdc++.so.6: no version information available (required by /usr/bin/fam)
qtparted: /usr/lib/libstdc++.so.6: no version information available (required by /opt/qt/lib/libqt-mt.so.3)
all kde apps produces such error messages
recompiling of qtparted is not working stops with checking for Qt... configure: error: Qt (>= Qt 3.1.0 and < Qt 3.4.0) (library qt-mt) not found. Please check your installation!
don't know if more is affected
This task depends upon

Closed by  Judd Vinet (judd)
Tuesday, 09 November 2004, 21:30 GMT
Reason for closing:  Fixed
Comment by Shahar (sweiss) - Wednesday, 08 September 2004, 09:06 GMT
I get similar messages about the missing version information when trying to run `man`, bzflag, and probably some other applications.
Comment by Tobias Powalowski (tpowa) - Wednesday, 08 September 2004, 10:55 GMT
i tried to recompile qt
doesn't work stops with an error
libGLU.so error
i try to recompile xorg now
perhaps it helps
Comment by Tobias Powalowski (tpowa) - Wednesday, 08 September 2004, 12:08 GMT
xorg doesn't work to recompile
Comment by Tobias Kieslich (tobias) - Wednesday, 08 September 2004, 13:55 GMT
Ok, it seems this can be tracked down to any C++ related program. I tried
to follow the dependency chain on aspell (which is short aspell-de -> aspell gcc) and found that recompiling aspell and then aspell-de solves the issue. And so it will solve the issues on xorg and so on but it does mean we have to recompile everything which depends on libstdc++.
Grmpf.
State of things is that programs work just can't be rebuilt.
Comment by Damir Perisa (damir.perisa) - Wednesday, 08 September 2004, 19:32 GMT
o man, o man ...

[damir@Asteraceae /]$ man man
/usr/bin/gtbl: /usr/lib/libstdc++.so.6: no version information available (required by /usr/bin/gtbl)
/usr/bin/gtbl: /usr/lib/libstdc++.so.6: no version information available (required by /usr/bin/gtbl)
[damir@Asteraceae /]$ pacman -Qo /usr/bin/gtbl
/usr/bin/gtbl is owned by groff 1.19.1-2

Comment by Judd Vinet (judd) - Wednesday, 08 September 2004, 20:09 GMT
Groff, fam, and aspell have been rebuilt. I'll start on some other rebuilds now.

As Tobias said, it seems that these packages all work, they just complain about version information.

Please note any other packages in Current/Extra that will require a rebuild. So far I have these from Current:

fam, groff, cdrdao, firefox, abiword, xscreensaver, aspell
Comment by Judd Vinet (judd) - Wednesday, 08 September 2004, 22:20 GMT
Firefox and abiword are rebuilt now.
Comment by Jeffrey Chu (jochu) - Thursday, 09 September 2004, 01:29 GMT
In addition to the list:
mozilla, and galeon
Comment by Dennis (Iolo) - Thursday, 09 September 2004, 03:29 GMT
Applies to worker the xscreensaver pkgs.
Comment by William DeMoss II (wdemoss) - Thursday, 09 September 2004, 14:57 GMT
nmap needs it too, here is the error:

nmap: /usr/lib/libstdc++.so.6: no version information available (required by nmap)
nmap: /usr/lib/libstdc++.so.6: no version information available (required by nmap)
Comment by Tobias Powalowski (tpowa) - Thursday, 09 September 2004, 15:18 GMT
xorg + qt are also needed
Comment by Dennis (Iolo) - Thursday, 09 September 2004, 19:30 GMT
Err... make that it applies to the worker pkg.
Comment by Judd Vinet (judd) - Thursday, 09 September 2004, 19:55 GMT
nmap and xscreensaver are rebuilt
Comment by Tobias Powalowski (tpowa) - Thursday, 09 September 2004, 21:33 GMT
here xorg error new 6.8 release is the same with 6.7 but neri seems to get a working build:
cpp -undef -traditional -D__apploaddir__=/usr/X11R6/lib/X11/app-defaults -D__appmansuffix__=1x -D__filemansuffix__=5x -D__libmansuffix__=3x -D__miscmansuffix__=7 -D__drivermansuffix__=4 -D__adminmansuffix__=8 -D__projectroot__=/usr/X11R6 -D__xconfigfile__=xorg.conf -D__xconfigdir__=/usr/X11R6/lib/X11 -D__xlogfile__=Xorg -D__xservername__=Xorg -D__xorgversion__='"" ""' -D__vendorversion__="`echo 6 8 0 | sed -e 's/ /./g' -e 's/^/Version\\\ /'` X.Org" \
< xkbcomp.man | sed -e '/^# *[0-9][0-9]* *.*$/d' -e '/^#line *[0-9][0-9]* *.*$/d' -e '/^[ ]*XCOMM$/s/XCOMM/#/' -e '/^[ ]*XCOMM[^a-zA-Z0-9_]/s/XCOMM/#/' -e'/^[ ]*XHASH/s/XHASH/#/' -e '/\@\@$/s/\@\@$/\\/' >xkbcomp._man; \
fi
rm -f xkbcomp.1x.html xkbcomp.1x-html
../../config/util/rman -f HTML < xkbcomp._man \
> xkbcomp.1x-html && mv -f xkbcomp.1x-html xkbcomp.1x.html
rm -f ../../exports/bin/xkbcomp
cd ../../exports/bin && ln -s ../../programs/xkbcomp/xkbcomp .
making all in programs/xkbcomp/compat...
make[5]: Entering directory `/home/tobias/xorg/src/xc/programs/xkbcomp/compat'
rm -f compat.dir
LD_LIBRARY_PATH=../../../exports/lib XLOCALEDIR=../../../exports/lib/locale ../../../exports/bin/xkbcomp -lfhlpR -o compat.dir '*'
../../../exports/bin/xkbcomp: error while loading shared libraries: libfakeroot.so.0: cannot open shared object file: No such file or directory
make[5]: *** [compat.dir] Fehler 127
make[5]: Leaving directory `/home/tobias/xorg/src/xc/programs/xkbcomp/compat'
make[4]: *** [all] Fehler 2
make[4]: Leaving directory `/home/tobias/xorg/src/xc/programs/xkbcomp'
make[3]: *** [all] Fehler 2
make[3]: Leaving directory `/home/tobias/xorg/src/xc/programs'
make[2]: *** [all] Fehler 2
make[2]: Leaving directory `/home/tobias/xorg/src/xc'
make[1]: *** [World] Fehler 2
make[1]: Leaving directory `/home/tobias/xorg/src/xc'
make: *** [World] Fehler 2
Comment by Damir Perisa (damir.perisa) - Friday, 10 September 2004, 02:05 GMT
foobilliard segfaults
neverball segfaults

both use sdl -> maybe sdl trouble
(but apricots, also using sdl, works fine)

gdb panics kernel (maybe only mm-specific)

kde crash-handler also panics kernel (maybe only mm-specific)

arts sometimes freezes and need to be killed


Comment by Damir Perisa (damir.perisa) - Friday, 10 September 2004, 02:07 GMT
not sdl - it's mesa:

[damir@Asteraceae ~]$ neverball
/usr/share/neverball/bin/neverball: /usr/lib/libGL.so.1: no version information available (required by /usr/share/neverball/bin/neverball)
Fatal signal: Segmentation Fault (SDL Parachute Deployed)
[damir@Asteraceae ~]$ pacman -Qo /usr/lib/libGL.so.1
/usr/lib/libGL.so.1 is owned by mesa 6.0.1-1
Comment by Tobias Powalowski (tpowa) - Friday, 10 September 2004, 16:02 GMT
here new one wich need to be rebuilt
qt , libtag, doxygen, mozilla
Comment by Elias Guerrero (hyp0luxa) - Friday, 10 September 2004, 17:47 GMT
kdelibs also needs to be rebuilt
Comment by Tobias Powalowski (tpowa) - Friday, 10 September 2004, 18:04 GMT
i'm working already on the kde issues
kde needs recompile
and probably all kde apps too
Comment by Eric Belanger (Snowman) - Friday, 10 September 2004, 19:00 GMT
xlockmore will need to be rebuilt.
Error message:

xlock: /usr/lib/libstdc++.so.6: no version information available (required by xlock)
xlock: /usr/lib/libstdc++.so.6: no version information available (required by xlock)
xlock: /usr/lib/libstdc++.so.6: no version information available (required by /usr/X11R6/lib/libGLU.so.1)
xlock: /usr/lib/libstdc++.so.6: no version information available (required by /usr/X11R6/lib/libGLU.so.1)
Comment by Jeramy Rutley (mr_ed) - Saturday, 11 September 2004, 18:03 GMT
Here's a couple more:

blackjack
galeon
gnometris
nspluginscan
nspluginviewer
Comment by Mike Perry (mikep) - Saturday, 11 September 2004, 19:54 GMT
qmake: /usr/lib/libstdc++.so.6: no version information available (required by qmake)
Comment by Xavier de Labouret (zezaz) - Monday, 13 September 2004, 11:42 GMT
One more:

mozilla-thunderbird
Comment by Kevin McKinney (kevinm) - Monday, 13 September 2004, 21:46 GMT
bincimap does not work either and could no longer use SquirrelMail.

A telnet to port 143 suggests that the problem is due to libstdc++.so.6.0.2 being incompatible with the current version of bincimap.

A symlink to libstdc++.so.6.0.1 from the gcc-3.4.1-2 package is a quick fix.

Error Message from bincimap

telnet localhost 143
Trying 127.0.0.1...
Connected to localhost..
Escape character is '^]'.
bincimap-up: /usr/lib/libstdc++.so.6: no version information available (required by bincimap-up)
bincimap-up: /usr/lib/libstdc++.so.6: no version information available (required by bincimap-up)
* OK Welcome to Binc IMAP Copyright (C) 2002-2004 Andreas Aardal Hanssen at 2004-09-13 14:39:05 PDT
Comment by Jeramy Rutley (mr_ed) - Wednesday, 15 September 2004, 17:48 GMT
[root@jester jeramy]# /etc/rc.d/ptal-init start

Stopping the HP OfficeJet Linux driver.
Starting the HP OfficeJet Linux driver.
ptal-mlcd: /usr/lib/libstdc++.so.6: no version information available (required by ptal-mlcd)
ptal-mlcd: /usr/lib/libstdc++.so.6: no version information available (required by ptal-mlcd)
mlc:usb:psc_1200_series
ptal-mlcd: /usr/lib/libstdc++.so.6: no version information available (required by ptal-mlcd)
ptal-mlcd: /usr/lib/libstdc++.so.6: no version information available (required by ptal-mlcd)
Comment by Tobias Powalowski (tpowa) - Friday, 17 September 2004, 10:53 GMT
hpoj rebuild
should be fixed
Comment by Johannes Held (johannesheld) - Friday, 17 September 2004, 19:09 GMT
Hello, pdflatex and idesk need to be recompiled, too.
[~] pdflatex
pdflatex: /usr/lib/libstdc++.so.6: no version information available (required by pdflatex)
pdflatex: /usr/lib/libstdc++.so.6: no version information available (required by pdflatex)
...
[~] idesk
idesk: /usr/lib/libstdc++.so.6: no version information available (required by idesk)
idesk: /usr/lib/libstdc++.so.6: no version information available (required by idesk)

Thank you, Johannes Held
Comment by LavaPunk (LavaPunk) - Saturday, 18 September 2004, 23:09 GMT
xdiskusage needs to be rebuilt
Comment by Johannes Jordan (FoPref) - Sunday, 19 September 2004, 12:13 GMT
xpdf also complains
Comment by Justin Smithies (justinsmithies) - Tuesday, 21 September 2004, 17:01 GMT
Fluxbox-devel and fluxbox give the error

/usr/lib/libstdc++.so.6: no version information available

Maybe these too need to be rebuilt ?
Comment by Tobias Kieslich (tobias) - Tuesday, 21 September 2004, 17:25 GMT
fluxbox also throws this error, isn't it linked against libstd++.so.5 wich is a gcc3.2 combat?
Comment by Mr Green (MrGreen) - Wednesday, 22 September 2004, 09:52 GMT
I am having the same problems ... Is there any news on a fix ...

maybe symlink broken ????
Comment by Shahar (sweiss) - Friday, 24 September 2004, 16:51 GMT
bzflag also needs a rebuild
Comment by Judd Vinet (judd) - Friday, 24 September 2004, 16:57 GMT
id3lib needs a rebuild
Comment by Gene Seto (Hum) - Saturday, 09 October 2004, 21:29 GMT
wvdial needs to be rebuilt
wvdial: /usr/lib/libstdc++.so.6: no version information available (required by /usr/lib/libwvutils.so.3.75)
wvdial: /usr/lib/libstdc++.so.6: no version information available (required by /usr/lib/libwvutils.so.3.75)
wvdial: /usr/lib/libstdc++.so.6: no version information available (required by /usr/lib/libwvstreams.so.3.75)
wvdial: /usr/lib/libstdc++.so.6: no version information available (required by /usr/lib/libwvstreams.so.3.75)
Comment by Judd Vinet (judd) - Tuesday, 09 November 2004, 21:29 GMT
neri reports that this warning has gone away in gcc 3.4.3

Loading...