Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13994 - ncursesw: some programs want /usr/include/ncursesw/

Attached to Project: Arch Linux
Opened by farvardin (farvardin) - Saturday, 28 March 2009, 10:42 GMT
Last edited by Allan McRae (Allan) - Sunday, 29 March 2009, 08:34 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

It seems on some distributions (at least on Debian) ncurses and ncursesw libraries are kept in different folders, for example /usr/include/ncursesw/

Some programs relies on this, and include ncursesw like this:

#include <ncursesw/ncurses.h>

which will fail on archlinux, unless you correct the sources.

If those headers are separated like this on every other distribution except archlinux, a solution would be to add symbolic links from /usr/include/ncurses.h to /usr/include/ncursesw/ncurses.h and so on for files like this (a debian system gives: curses.h cursesm.h cursslk.h form.h ncurses.h term.h tic.h cursesapp.h cursesp.h eti.h menu.h ncurses_dll.h term_entry.h unctrl.h cursesf.h cursesw.h etip.h nc_tparm.h panel.h termcap.h)


Additional info:
* package version(s) : 5.7-2


Steps to reproduce:

wget http://spellbreaker.org/~chrender/fizmo/fizmo-0.6.0.tar.gz
tar xfvz fizmo-0.6.0.tar.gz
cd fizmo-0.6.0
ln -s config.default.mk config.mk
make




This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 29 March 2009, 08:34 GMT
Reason for closing:  Not a bug
Comment by Allan McRae (Allan) - Saturday, 28 March 2009, 14:55 GMT
Surely a configure script should pick this up... Not we don't actually distribute the non-wide character headers at all.

Given the vast majority of programs do deal with this properly, I think I will close this as "not a bug".

Loading...