Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13950 - Incorrect symbolic links for /dev/<optical drives> block devices

Attached to Project: Arch Linux
Opened by Mathew de Detrich (PandaMine) - Wednesday, 25 March 2009, 07:37 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 30 March 2009, 04:55 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Simply put, the symbolic links for the following block devices point to the incorrect locations which causes mounting from /dev/cdrom etc etc to fail. Here is the output of ls -l

lrwxrwxrwx 1 root root 21 2009-03-26 04:42 cdrom -> /dev/cd/cdrom-2:0:0
:0
lrwxrwxrwx 1 root root 21 2009-03-26 04:42 cdrom0 -> /dev/cd/cdrom-2:0:
0:0
lrwxrwxrwx 1 root root 20 2009-03-26 04:42 cdrw -> /dev/cd/cdrw-2:0:0:0
lrwxrwxrwx 1 root root 20 2009-03-26 04:42 cdrw0 -> /dev/cd/cdrw-2:0:0:

However when we go to /dev/cd/
lrwxrwxrwx 1 root root 6 2009-03-26 04:45 cdrom- -> ../sr0
lrwxrwxrwx 1 root root 6 2009-03-26 04:45 cdrw- -> ../sr0
lrwxrwxrwx 1 root root 6 2009-03-26 04:45 dvd- -> ../sr0

As you can see the files in /dev/cd/ are actually cdrom-/cdrw-/dvd- instead of cdrom/cdrw/dvd

Additional info:
* package version(s)
* config and/or log files etc.
Latest arch pacman -Syu

Steps to reproduce:
N/A
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 30 March 2009, 04:55 GMT
Reason for closing:  Fixed
Comment by Mathew de Detrich (PandaMine) - Thursday, 26 March 2009, 03:23 GMT
Note that this can be related to the following bug
http://bugs.archlinux.org/task/12177

However I am using the stock kernel for i686
Comment by Mathew de Detrich (PandaMine) - Thursday, 26 March 2009, 03:25 GMT
This is also probably a duplicate of this bug
http://bugs.archlinux.org/task/13156
Comment by Tobias Powalowski (tpowa) - Saturday, 28 March 2009, 12:14 GMT
should work again with udev-140-2
Comment by Tobias Powalowski (tpowa) - Sunday, 29 March 2009, 17:29 GMT
any update on this guys?
Comment by Andreas Tiemeyer (grey) - Sunday, 29 March 2009, 21:47 GMT
Upgrading udev to 140-2 fixed the problem for me.

Loading...