Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13934 - GnuPG2 2.0.11 missing GTK1 dependency

Attached to Project: Arch Linux
Opened by Dave (DaveCode) - Tuesday, 24 March 2009, 05:11 GMT
Last edited by Hugo Doria (hdoria) - Friday, 10 April 2009, 19:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Hugo Doria (hdoria)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

GPG2 needs GTK 1. Dependency not listed with package.

* package version(s)
2.0.11 x86_64

* config and/or log files etc.
defaults

Steps to reproduce:
(make sure your sys has no GTK1 stuff, as did mine)
# pacman -S gnupg2
# gpg2 --gen-key
(hit all the defaults, get result that)
pinentry: error while loading shared libraries: libgtk-1.2.so.0: cannot open shared object file: No such file or directory
This task depends upon

Closed by  Hugo Doria (hdoria)
Friday, 10 April 2009, 19:48 GMT
Reason for closing:  Works for me
Comment by Andreas Radke (AndyRTR) - Tuesday, 24 March 2009, 08:14 GMT
what is the pkg version of pinentry? are you running testing?
Comment by Hugo Doria (hdoria) - Tuesday, 24 March 2009, 11:27 GMT
pinentry 0.7.5-5 (from testing) is working fine here:

$ pinentry
OK Your orders please

Also gpg2 works fine here:

$ gpg2 --gen-key
gpg (GnuPG) 2.0.11; Copyright (C) 2009 Free Software Foundation, Inc.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Please select what kind of key you want:
(1) DSA and Elgamal (default)
(2) DSA (sign only)
(5) RSA (sign only)
Your selection?

Loading...