Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13897 - [vim] Update python.vim to match version of Python in Arch

Attached to Project: Arch Linux
Opened by Jake Muss (jaketmuss) - Saturday, 21 March 2009, 06:51 GMT
Last edited by Dan Griffiths (Ghost1227) - Sunday, 18 April 2010, 07:39 GMT
Task Type Feature Request
Category Upstream Bugs
Status Closed
Assigned To Tobias Kieslich (tobias)
Dan Griffiths (Ghost1227)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

As Arch is currently using python 2.6.1, it would be helpful if vim had the matching syntax file for Python (/usr/share/vim/syntax/python.vim).

This is where you can find the various versions of python.vim:
http://www.vim.org/scripts/script.php?script_id=790

The file for 2.6.1 is:
http://www.vim.org/scripts/download_script.php?src_id=9262

Currently arch ships with a version for Python 2.4 from 2006:

" Vim syntax file
" Language: Python
" Maintainer: Neil Schemenauer <nas@python.ca>
" Updated: 2006-10-15
" Added Python 2.4 features 2006 May 4 (Dmitry Vasiliev)



Closed by  Dan Griffiths (Ghost1227)
Sunday, 18 April 2010, 07:39 GMT
Reason for closing:  Fixed
Comment by Tobias Kieslich (tobias) - Thursday, 25 June 2009, 16:24 GMT
we always pull the runtime files from the vim server, so when vim says there are new files for the runtime available we have them in newer releases. 7.2.218 just hit testing. can you check the version from there?
Comment by Thomas Dziedzic (tomd123) - Wednesday, 12 August 2009, 15:21 GMT
I can confirm the same old file in vim 7.2.65-1.1 which is in extra.

And I can confirm this in vim-7.2.234-1-x86_64.pkg.tar.gz which I got from testing.

This file is *old*.
Comment by Thomas Dziedzic (tomd123) - Thursday, 13 August 2009, 03:04 GMT
Wow, I just updated my python.vim file and you can see a big difference in python syntax highlighting!
It now has the ability to highlight values being assigned to variables. :)

I can maybe take a look at what the problem here is because I really like the newer python.vim (2+ year difference).
If python.vim is affected, then maybe others are affected also.
Hopefully I will have some spare time to look into this.f
Comment by Tobias Kieslich (tobias) - Thursday, 13 August 2009, 06:01 GMT
Vim has a way to update their runtime and we honour that update method in the build script. So why would they maintain a different version of the file and don;t merge it with the runtime updates. That sounds like an upstream issue to me.
Comment by Tobias Kieslich (tobias) - Sunday, 13 September 2009, 22:49 GMT
This is an upstream issue.
Comment by Jacob (Jacob_) - Sunday, 13 September 2009, 23:07 GMT
I do agree that this is an upstream issue and is unlikely to change.

However, as arch provides a certain version of python, should it provide a matching set vim files?

Maybe this is therefore an issue for the python package.
Comment by Tobias Kieslich (tobias) - Monday, 14 September 2009, 00:22 GMT
I would agree that it would be probably a good idea to ship the proper vim file with the python package. But either way we would have to hack in vim for that because we would have to remove the standard vim one to avoid conflicts with the python package then. Non of these is desire able because it leave us with hacking vim anytime some application specific *.vim file is out of date. That's just Pandoras box.
Even python.org says that the current production versions are 2.6.2 and 3.1.1 That puts the ball back to vim's upstream, because 2.4 is clearly not 'current'
Comment by Jacob (Jacob_) - Saturday, 19 September 2009, 12:21 GMT
/usr/share/vim/vimfiles appears to be searched before /usr/share/vim/vim<version> to enable distros to override the default vim runtime files. Would it be appropriate for the python package to place a syntax file there?
The python vim syntax file is not updated very often and given the number of python users that use vim it would hopefully not be to much extra work for the python pkg maintainer, and could be repeated for any other packages that have more up-to-date syntax files.
This would also remove any effort from the vim maintainer, enabling this package to be properly maintained.
Comment by Tobias Kieslich (tobias) - Saturday, 19 September 2009, 18:11 GMT
Hm, that does sound like a solution, and since we ship only one package of the python interpreter, we should not run into conflicts.
Comment by Laszlo Papp (djszapi) - Saturday, 03 October 2009, 22:32 GMT
It's not a vim maintaining problem then, reassign it to the python Maintainer. I don't think Tobias should do anything with it.
Comment by Tobias Kieslich (tobias) - Sunday, 04 October 2009, 00:00 GMT
I do agree that it is pointless to have a python 2.4 file as part of vim because the current version is 2.6. I think it's a clear error on vim's upstream side. The problem with fixing it for archlinux is that vim ships with a bajillion .vim files and there is a chance that a good bunch of them is out of date. And fix ing that is a night mare where to draw the line.
If we move the problem into the python package(s) we need at least remove the python.vim file from the package itself.
Comment by Allan McRae (Allan) - Sunday, 04 October 2009, 00:40 GMT
Python does not ship with a vim syntax file and I have no intention of adding one to python package. Create a "vim-python" (or something like that) package if you want one.
Comment by Allan McRae (Allan) - Sunday, 04 October 2009, 00:41 GMT
Not a python issue -> unassigning myself
Comment by Xavier (shining) - Wednesday, 28 October 2009, 14:01 GMT
I suppose that during 7 months, upstream has been contacted several times about this, right ?
Did they provide any reasons for not updating ?
Comment by Sven-Hendrik Haase (Svenstaro) - Saturday, 06 February 2010, 15:28 GMT
Here, I bothered upstream a bit, let's see what comes out of it.
http://groups.google.com/group/vim_dev/browse_thread/thread/51e8e862c5ef4460?hl=en
Comment by Xavier (shining) - Monday, 08 February 2010, 15:32 GMT
@Sven : thanks for bothering.

So it looks like it's not an upstream problem after all, the hg repository is up-to-date.
You can use this package : http://aur.archlinux.org/packages.php?ID=33422
Comment by Sven-Hendrik Haase (Svenstaro) - Monday, 08 February 2010, 15:44 GMT
How long does a vim release usually take? It might be worth to update the runtime scripts using the hg repo and put it into the current Arch vim package.
Comment by Xavier (shining) - Monday, 08 February 2010, 17:29 GMT
http://ftp.vim.org/pub/vim/unix/
[ ] vim-7.0.tar.bz2 07-May-2006 16:17 6.3M
[ ] vim-7.1.tar.bz2 12-May-2007 14:10 6.6M
[ ] vim-7.2.tar.bz2 06-Sep-2008 16:35 6.9M
Comment by Sven-Hendrik Haase (Svenstaro) - Monday, 08 February 2010, 20:07 GMT
:(
So maybe just provide a script to get the updated files? Or does vim-hg do for now?
Comment by Xavier (shining) - Monday, 08 February 2010, 20:47 GMT
There is already a script to get the updated runtime files.
I just saw that the vim package was built on 30/09 but the python.vim file was put on 28/10 :
http://ftp.vim.org/pub/vim/runtime/syntax/ python.vim
So maybe it would be sufficient to rebuild the vim package now to pick an up-to-date version of python.vim .

But you should probably read this discussion to know my opinion on the matter :
http://mailman.archlinux.org/pipermail/arch-dev-public/2009-October/013844.html
The only thing that changed since then is that instead of an unofficial git repo, there is now an official hg repository which gives you an easy way to get the latest code and runtime.
So I highly recommend using vim-hg rather than arch package :)
Comment by Sven-Hendrik Haase (Svenstaro) - Monday, 08 February 2010, 21:33 GMT
Will check it out. However, can we find an official way so that users not using vim from AUR may benefit as well? What's with the myriad of patches anyway? I thought Arch philosophy was not use patches unless completely required.
Comment by Xavier (shining) - Friday, 12 February 2010, 23:39 GMT
Arch philosophy is mainly about unofficial patches, not official ones.

As I showed you, vim releases are quite rare, and last one is quite old. Applying all the patches (I agree that's silly) is actually the same than using the development version/repository.

There are several projects who don't release often enough, and you have to use a development version or snapshot to get all the latest fixes and/or improvements.
This seems to be the case for the toolchain : binutils,glibc,gcc
Also libfetch has no release.
I am sure there are more examples, and these are all in core.
Comment by Paul Mattal (paul) - Saturday, 06 March 2010, 14:14 GMT
Because we use a newer python, it seems to make sense to me that our python.vim should match it.

In general, I think it is good to be conservative and keep to release versions only, but here it seems like there's a demonstrated need, based on the version of a related package.

So I think we should (narrowly) grab the newer python.vim.

Do others agree/disagree? Tobias, I know you have a lot of insight and experience here.
Comment by Paul Mattal (paul) - Saturday, 06 March 2010, 14:24 GMT
Am I correct in thinking that if we do some auto update solution from:

http://bugs.archlinux.org/task/14640

that this problem goes away? I see a newer python.vim in the hg repo.

This is not to say we'd do 14640, but I was just noticing the relationship.
Comment by Dan Griffiths (Ghost1227) - Sunday, 18 April 2010, 07:39 GMT
Fixed in [testing]

Loading...