Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13872 - [avahi] initscript needs dbus initscript as dependency

Attached to Project: Arch Linux
Opened by Jan Winkelmann (keks) - Thursday, 19 March 2009, 14:26 GMT
Last edited by Dan Griffiths (Ghost1227) - Saturday, 27 February 2010, 03:25 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Avahi needs DBus to work properly. But when starting /etc/rc.d/avahi, he doesn't depend on it.

Additional info:
* package version(s)
avahi: 0.6.24-1
dbus 1.2.4.4permissive-1
dbus-core 1.2.4.4permissive-1 (base)

* config and/or log files etc.
fixed /etc/rc.d/avahi-daemon attached

Steps to reproduce:
This task depends upon

Closed by  Dan Griffiths (Ghost1227)
Saturday, 27 February 2010, 03:25 GMT
Reason for closing:  Implemented
Comment by Roman Kyrylych (Romashka) - Thursday, 28 May 2009, 18:54 GMT
I don't think that there is a requirement for daemons to load dbus if they depend on it, it's optional feature of hal and maybe some other rc.d scripts,
but it's up to the maintainer to decide.
Comment by Gerardo Exequiel Pozzi (djgera) - Thursday, 30 July 2009, 05:59 GMT
  • Field changed: Summary ([avahi-daemon] initscript needs dbus initscript as dependency → [avahi] initscript needs dbus initscript as dependency )
status of this in avahi-0.6.25-1?

Loading...