Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13705 - Syslog 3.0.1-4 shuts down if config file from package is written as .pacnew file

Attached to Project: Arch Linux
Opened by Mårten Olsson (maos) - Sunday, 08 March 2009, 22:47 GMT
Last edited by Aaron Griffin (phrakture) - Monday, 09 March 2009, 19:58 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
If the config file is written as /etc/syslog-ng.conf.pacnew then syslog-ng will shut down after printing a lot of warnings (which for me scrolled of the top of my screen).
This of course stops the log-files from being updated.

During some other update the user modified config file was saved as .pacsave and the new config file overwrote the config.
When this update goes to core my opinion is that this update should do the same thing with the config file (and printing a warning when upgrading).

Additional info:
* package version(s)
testing/syslog-ng 3.0.1-4

* config and/or log files etc.
/etc/syslog-ng.conf
/etc/syslog-ng.conf.pacnew

Steps to reproduce:
have a usermodified config file for syslog-ng and update to latest version in testing.
This task depends upon

Closed by  Aaron Griffin (phrakture)
Monday, 09 March 2009, 19:58 GMT
Reason for closing:  Not a bug
Additional comments about closing:  This case is covered by a post-install message as is the norm with changes of this type.
Comment by Mårten Olsson (maos) - Sunday, 08 March 2009, 23:32 GMT
Fot information that made me realize that it wasn't .pacsave thing for the update case but but there was some update that did something "special" to backup user modified configs and install new one to keep it running.

Alternative is of course to have it has a news item or similar to make users really pay attention that this can happen.

I know this is not a bug as such but more "I think this needs to be handled in a way to really keep the syslog running".
And it was maybe wrong to open this bug... But I really think special steps (soemhow) should be taken to keep the syslog running when getting this update.
Comment by Aaron Griffin (phrakture) - Monday, 09 March 2009, 17:51 GMT
I don't think I understand how a running syslogd daemon fails like this, as the pacnew file has nothing to do with it.

IF the daemon is restarted, I expect it will error, as the 3.X series has config file changes. But I don't see how this affects a RUNNING daemon. Could you provide some of the error messages?
Comment by Mårten Olsson (maos) - Monday, 09 March 2009, 18:50 GMT
Sorry for not being clear, I got the messages at a restart....

Must stop writing these things late at night....
Comment by Aaron Griffin (phrakture) - Monday, 09 March 2009, 19:10 GMT
So, did you get the message that said:
[
Attention syslog-ng update:
Configuration file syntax has changed. Make sure to update /etc/syslog-ng.conf
]

That was the point of this - the config file syntax changed and user intervention is needed. Remember: Arch doesn't hold your hand for these things.
Comment by Mårten Olsson (maos) - Monday, 09 March 2009, 19:12 GMT
Must have missed that one... Maybe scrolled up the top...

Loading...