Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#13651 - X not resuming after hibernate/suspend with xf86-video-intel and 2.6.2 and xorg-server 1.6.0

Attached to Project: Arch Linux
Opened by Blazej (blasse) - Tuesday, 03 March 2009, 18:48 GMT
Last edited by Jan de Groot (JGC) - Saturday, 30 May 2009, 16:44 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 12
Private No


After upgrading to xserver 1.6 with intel 2.6 drivers, computer no longer restart X after resuming from standby. It remains with black screen with locked cursor. Computer is not responding.
The same happens when swithcing back to X from VC.

Additional info:
xorg-server 1.6.0-1
xf86-video-intel 2.6.2-1

Tried with EXA and UXA enabled.

Steps to reproduce:
Upgrade to xserver and intel driver from testing.
Suspend and resume.
This task depends upon

Closed by  Jan de Groot (JGC)
Saturday, 30 May 2009, 16:44 GMT
Reason for closing:  Fixed
Additional comments about closing:  Seems to work fine with current kernel/xorg/libgl/intel-dri/xf86-video-i ntel.
Comment by Blazej (blasse) - Tuesday, 03 March 2009, 18:56 GMT
Ok, not a duplicate - reported bug is about crashing with every X start, not after resuming. If someone could change category to testing, I would be grateful.
Comment by Blazej (blasse) - Wednesday, 04 March 2009, 18:10 GMT
Gentoo has similar bug opened, but without resolution for now:
Comment by Cedric Staub (csstaub) - Wednesday, 04 March 2009, 20:26 GMT
I can confirm the same problem using xorg-server 1.5.3-4 with xf86-video-intel-newest 2.6.2 (from AUR) with a 'Intel Mobile 4' card, but I can only consistently reproduce the problem by suspending. Sometimes X also crashes with the same symptoms when switching back from VC, but only rarely. I can then only reboot the system using SysRq+reisub. Ubuntu has a similar bug, too ( but their proposed fix (offline second CPU) didn't solve this for me. I haven't tried xorg-server 1.6 yet, but will do so tomorrow.
Comment by Blazej (blasse) - Wednesday, 04 March 2009, 21:03 GMT
Patch for Ubuntu bug should be merged to 2.6.28 kernel, so this is probably something different...
Comment by Jan Spakula (bender02) - Thursday, 05 March 2009, 06:59 GMT
I can confirm the original report, same problem here on intel GM965, xf86-video-intel-2.6.2-1 (and also 2.6.3, manually built via abs).
Comment by Mihael Pranjić (tux) - Thursday, 05 March 2009, 08:26 GMT
Same experience here with an asus EEEPC 1000h ...
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)

after upgrade to:
xorg-server 1.6.0-1
xf86-video-intel 2.6.2-1

Xorg doesnt start correctly.. I get black screen with some blue lines on it flickering, and thats it
Bug or feature?
Comment by Mihael Pranjić (tux) - Thursday, 05 March 2009, 08:33 GMT
I think the title should be changed btw
Comment by Blazej (blasse) - Thursday, 05 March 2009, 09:02 GMT
It should be if you are encountering the same problem. I mine X starts correctly, just resume and vc switching is broken.
BTW. Going standby from console resumes just fine, but switching to X froze computer.
Comment by Cedric Staub (csstaub) - Thursday, 05 March 2009, 10:02 GMT
I just upgraded my system to testing and I am now running xorg-server-1.6.0-1 with xf86-video-intel 2.6.3-1, and interestingly enough I was just able to suspend and resume successfully using the command 's2ram -f -p -m'. Twice with one and twice with two CPUs.
Comment by Blazej (blasse) - Thursday, 05 March 2009, 11:58 GMT
On my rig after update to 2.6.3 there is no change.
Comment by Matthias Dienstbier (fs4000) - Thursday, 05 March 2009, 16:32 GMT
Just found this bug, but I don't have the problem with Intel GMA X3100 (GM965) and testing enabled.
Comment by Blazej (blasse) - Thursday, 05 March 2009, 19:47 GMT
Trsted with: glproto-git intel-dri-git libdrm-git mesa-git and xf86-video-intel-git and problem still occurs.
Comment by Aren Olson (reacocard) - Thursday, 05 March 2009, 22:23 GMT
I can confirm this same issue on my intel X3100; vt switching and resume from suspend (via pm-utils) are broken. Maybe the intel driver is expecting KMS to be present to handle these tasks?
Comment by Cedric Staub (csstaub) - Friday, 06 March 2009, 09:53 GMT
After having left my laptop in suspended mode for more than 5 minutes, the problem is now back :-(. My XOrg logfiles complain contain the message "Freeing invalid memtype" right before the crash. I'm currently compiling kernel 2.6.29-rc7 to see if KMS will make a difference.
Comment by Cedric Staub (csstaub) - Friday, 06 March 2009, 12:04 GMT
I'm now running 2.6.29-rc7 with KMS enabled, and I can report the following things:
* After first boot, KMS broke my resolution (1280x800->1024x768). VC switching worked perfectly,
but after resuming from suspend I wasn't able to see X anymore (I ended up at vc/0).
* After getting X to ignore the (new) DVI1/2 outputs that showed up in xrandr in order to get the
resolution right I can now suspend, but VC switching doesn't work anymore... Ctrl+Alt+Fx simply
doesn't do anything.
Comment by Ray Rashif (schivmeister) - Friday, 06 March 2009, 22:30 GMT
Works fine here for suspend-to-ram, not suspend-to-disk (white screen). GMA 950, 945 chip.
Comment by Tapio Saarinen (tzar) - Friday, 06 March 2009, 23:21 GMT
I have this too, it's stopping me from using xorg-server 1.6 because I need suspend on my notebook :-(

Linux Whimsy 2.6.28-ARCH #1 SMP PREEMPT Sun Feb 22 11:00:30 CET 2009 x86_64 Intel(R) Pentium(R) Dual CPU T2370 @ 1.73GHz GenuineIntel GNU/Linux
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)

I couldn't see any relevant messages in the Xorg log when I tried previously. Also, s2ram fails too.
Comment by Blazej (blasse) - Sunday, 08 March 2009, 00:48 GMT
Updating to 2.6.3-2 changes nothing. Resume and VT switching still not working, unfortunately.
Comment by Aren Olson (reacocard) - Sunday, 08 March 2009, 06:39 GMT
I just upgraded to 2.6.29-rc7 and enabled KMS and UXA. With this setup, vt-switching and suspend are now working perfectly, so far as I can tell. Glxgears renders very badly, but everything else appears to work. However, performance is much worse than was obtained on .28 and EXA. EXA does not work with KMS enabled.
Comment by Aren Olson (reacocard) - Sunday, 08 March 2009, 19:17 GMT
After disabling KMS on 2.6.29-rc7 (via i915.modeset=0), all issues appear to be resolved. EXA runs flawlessly with as good performance as 2.6.28, suspend/resume works, vt-switching works, and glxgears and other opengl programs render perfectly on my X3100 (GM965).
Comment by Maxim (Mad Max) - Monday, 09 March 2009, 10:15 GMT
I can confirm exactly that issue with my ATI Card (fglrx). Computer freezes completely and doesn't resume after standby -> black screen with locked cursor.
Comment by Mihael Pranjić (tux) - Monday, 09 March 2009, 13:09 GMT
Mad Max -> As far as I know the ATI fglrx drivers do *NOT* work with xorg-server-1.6.x at the moment, I am wondering why you get anything else but something like "fglrx- no such driver"
Comment by Maxim (Mad Max) - Monday, 09 March 2009, 18:05 GMT
tux, you are right, i was writing it from windows being @ work.
BUT, the problem persists on:

X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.27-ARCH x86_64
Current Operating System: Linux starlight 2.6.28-ARCH #1 SMP PREEMPT Sun Feb 22 11:00:30 CET 2009 x86_64
Build Date: 17 December 2008 10:46:49PM
Comment by Jan Spakula (bender02) - Tuesday, 10 March 2009, 08:26 GMT
I can confirm Aren Olson's finding: everything works with 2.6.29-rc7 kernel, modesetting disabled, EXA, nothing else in xorg.conf, on my X3100 (=GM965).
Comment by Jan Spakula (bender02) - Tuesday, 10 March 2009, 09:08 GMT
By the way, as mentioned on forums regarding this bug, some gentoo guys have the same problem:
(and upstream follow-up)
Comment by Adrian C. (anrxc) - Tuesday, 10 March 2009, 19:29 GMT
Hi, for me the problem is much worse (on GM965) because it locks up not only after resuming but in normal operation too. With first upgrade in the last days (xf86-video-intel-2.6.2 etc.) I started seeing these (but with no freezes):

[drm:i915_gem_object_pin] *ERROR* Failure to bind: -12<3>[drm:i915_gem_evict_something] *ERROR* inactive empty 1 request empty 1 flushing empty 1
[drm:i915_gem_object_bind_to_gtt] *ERROR* GTT full, but LRU list empty
[drm:i915_gem_object_pin] *ERROR* Failure to bind: -12<3>[drm:i915_gem_execbuffer] *ERROR* Failed to pin buffers -12

Then with todays updates (new kernel, driver, mesa etc.), machine would lock up and I started to see these:
kernel: [drm:i915_setparam] *ERROR* unknown parameter 4
Comment by Adrian C. (anrxc) - Tuesday, 10 March 2009, 23:14 GMT
Followup to my last comment; with the first error log nothing bad should happen as per this thread:

While another user reported his system freezing with the same message as in my 2nd error log, in this">
Comment by Adrian C. (anrxc) - Wednesday, 11 March 2009, 20:37 GMT
I managed to avoid freezing both in normal operation and on resume. Only thing that persists is freeze on VC switch but that is because of the kernel/i915 and I don't want to go to 2.6.29 yet. I downgraded to kernel26-, mesa-7.3-1 and libdrm-2.4.5-1, and upgraded xf86-video-intel to (2.7.0 rc1).
Comment by Martin Schmidt (Blind) - Wednesday, 18 March 2009, 15:38 GMT
My problems with coming back from suspend started with xf86-video-intel to :(
I am using the testing repo, but with a custom kernel - no KMS or anything special, though.
Comment by Aren Olson (reacocard) - Wednesday, 18 March 2009, 20:53 GMT
I can also confirm xf86-video-intel fails to resume properly, both on my custom 2.6.29-rc7 and on the stock kernel26. So far intel 2.6.3 and kernel 2.6.29-rc7 is the only combination that has worked perfectly.
Comment by Jan Spakula (bender02) - Wednesday, 18 March 2009, 21:30 GMT
Both vt switching and suspeding works fine here with 2.6.29-rc8, no KMS, xf86-video-intel (i915 driver, GM965 X3100)
Comment by Matthias Dienstbier (fs4000) - Wednesday, 18 March 2009, 23:02 GMT
Vt switching, suspend, hibernate are still working and 2D speed has improved again (2.6.3 was really slow). :-)
Comment by Adrian C. (anrxc) - Wednesday, 25 March 2009, 19:34 GMT
I installed kernel26 2.6.29 and then also upgraded libdrm and mesa (latest in testing) with xf86-video-intel installed already (from my previous comment). There are no problems; VT switching works, performance in games is the same, and most important no freezes on resume or normal operation.
Comment by Blazej (blasse) - Monday, 30 March 2009, 06:56 GMT
With Arch kernel 2.6.29 and xf86-video-intel suspending and VT switching works fine with EXA, but with UXA every switch or resume results in X logging out...
Comment by Felix Sipma (legrostdg) - Monday, 30 March 2009, 18:02 GMT
After updating on yesterday, the problem appeared for me too.
xorg-server 1.6.0-2
kernel26 2.6.29-4
Comment by Blazej (blasse) - Thursday, 02 April 2009, 20:15 GMT
With kms-enabled kernel the logout problem happens rarely. Is there any chance for kms-enabled official arch kernel? :)
Comment by Blazej (blasse) - Thursday, 02 April 2009, 20:19 GMT Comment by Felix Sipma (legrostdg) - Friday, 10 April 2009, 20:23 GMT
Everything works fine now :-)
I've updated:
testing/xorg-server 1.6.0-3 (xorg)
testing/xf86-video-intel 2.6.3-3 (xorg-video-drivers)
Comment by Blazej (blasse) - Saturday, 11 April 2009, 06:35 GMT
No more freezing since xf86-video-intel
But after resume from suspend X is reseting. I have to log in normally and all work is lost...
The same with KMS and non-KMS kernel. With xf86-video-intel-legacy everything is fine.

Is it still the same bug or should I make a new report?
Comment by Felix Sipma (legrostdg) - Saturday, 11 April 2009, 11:56 GMT
No, it is not... Mine was just freezing.
It seems to be a different bug, doesn't it?
I think you should make a new report and close that one. :-)
Comment by Josef Lusticky (EVRAMP) - Monday, 13 April 2009, 20:58 GMT
My notebook ("tuned" msi wind) resumes without any error after pm-hibernate, but it won't resume after pm-suspend.
However when using fallback image resuming from suspend works ok.
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
xorg-server 1.6.0-3, xf86-video-intel 2.6.3-3
Comment by Josef Lusticky (EVRAMP) - Tuesday, 14 April 2009, 19:41 GMT
Edit: When generating image with autodetect hook AFTER sata hook in mkinitcpio.conf, everything works fine.
Comment by Blazej (blasse) - Thursday, 16 April 2009, 18:22 GMT
2.7 driver seems to solve the problem
Comment by Adrian C. (anrxc) - Saturday, 18 April 2009, 15:00 GMT
I built xf86-video-intel 2.7.0 and while it brought some improvements to the desktop the freezes on VT switch re-appeared. I noticed it two times on shutdown or reboot, when a switch should occur the screen just stays black and the machine unresponsive. It is *without* KMS and with UXA enabled - I tested KMS and with it enabled I could not reproduce (besides it works differently) but unfortunately KMS has it's own bugs - with Tiling enabled on GM965/X3100 the screen is completely garbeled on X startup. I was also able to crash X (with KMS) by doing a few fast consecutive VT switches... So I would rather not use KMS, but without it the freezes are back.
Comment by Blazej (blasse) - Saturday, 18 April 2009, 15:08 GMT
For me there is no more freeze with 2.7. With EXA everything (switching VT, suspend/resume) works ok, with UXA X sometimes crash while exiting, with KMS X crashes after few VT switches (usually after 3rd-4th switch). Resuming from standby works like VT switch - works fine after start, but after switches or resuming earlier X crashes. But it seems to be another bug than earlier freezing :)
Comment by Lubos Kolouch (kolcon) - Tuesday, 21 April 2009, 06:32 GMT Comment by Blazej (blasse) - Saturday, 09 May 2009, 21:34 GMT
It works fine for me with kms and uxa on intel driver and kernel :)