Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13410 - hal fails with ntfs partitions

Attached to Project: Arch Linux
Opened by tuxce (tuxce) - Saturday, 21 February 2009, 23:25 GMT
Last edited by Andrea Scarpino (BaSh) - Monday, 27 April 2009, 16:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
In HAL 0.5.11-7, there is a patch "ntfs-mount-fix.patch" which make hal test for action "hal-storage-mount-fixed-extra-options", but there is no such action defined in PolicyKit files.

As result of that, HAL fails when it mounts ntfs partitions.

Instead of this patch, you can use this commit from hal git:
http://cgit.freedesktop.org/hal/commit/?id=25f9536d8cd4ff534eb73dc603a38b7d64ebf81e

The bug concerning ntfs was fixed before the commit in version 0.5.11:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=427109

Steps to reproduce:
just try to mount a ntfs partition with hal or an application like nautilus, pcmanfm ...
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Monday, 27 April 2009, 16:42 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in hal-0.5.12git20090406.46dc48-2
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 13 April 2009, 23:31 GMT
status with new HAL 0.5.12git20090406.46dc48-1 ?
Comment by Ionut Biru (wonder) - Monday, 13 April 2009, 23:38 GMT
doesn't work. same thing.
Comment by Ionut Biru (wonder) - Monday, 13 April 2009, 23:39 GMT
with "same thing" i wanted to say that nautilus ask for password and the partition doesn't been mounted.
Comment by Alessandro Doro (adoroo) - Tuesday, 14 April 2009, 01:20 GMT
With hal 0.5.11-7 I got the authentication dialog (in nautilus at least) but the NTFS volume was not mounted at all; I used 'sudo gnome-mount ...' to mount the partition.

Now, with hal 0.5.12git20090406.46dc48-1 I get:
Nautilus: "Cannot mount volume" dialog; "Cannot get volume.fstype.alternative".
sudo gnome-mount -p volumelabel: same error as above.
Pcmanfm: "Unable to mount device"; Error org.freedesktop.Hal.Device.Volume.UnknownFailure.
Comment by Alessandro Doro (adoroo) - Wednesday, 15 April 2009, 19:50 GMT
Now I can mount a NTFS volume by "sudo gnome-mount -p volumelabel" again (because of the ntfs-3g update to 2009.4.4-1?).

The problems still persist in nautilus o pcmanfm, but isn't this task a duplicate of  FS#12397 ?
Comment by tuxce (tuxce) - Wednesday, 15 April 2009, 21:09 GMT
didn't see #12397 before. (bad search words maybe)

Loading...