Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13394 - [celestia] dialogs broken

Attached to Project: Arch Linux
Opened by Connor Behan (connorbehan) - Friday, 20 February 2009, 18:24 GMT
Last edited by Ronald van Haren (pressh) - Tuesday, 30 June 2009, 12:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

Celestia won't display file dialogs correctly. There are missing spaces in the directory listing on the side and nothing shows up in the main panel. Trying to navigate to a particular directory makes it go into an infinite loop. My friend on ubuntu says this doesn't happen to him so please make sure the Arch patches aren't causing this.

Additional info:
* celestia 1.5.1
* default configuration and patching for the Arch version


Steps to reproduce:
Go into celestia, hit Ctrl+O and try to use the dialog that comes up.
This task depends upon

Closed by  Ronald van Haren (pressh)
Tuesday, 30 June 2009, 12:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  bug is fixed by updates of some other packages. the dialog works fine now.
Comment by Connor Behan (connorbehan) - Saturday, 21 February 2009, 01:46 GMT
Ok, this seems to be a "feature" of --with-gtk. If I compile --with-gnome the dialogs are fine. Everything else is the same except for the libgnomeui dependency and the gconf scehmas that get installed. The gcc43 patch has nothing to do with it.
Comment by Ronald van Haren (pressh) - Wednesday, 11 March 2009, 21:48 GMT
libgnomeui brings in a total of 40Mb of deps which is almost the size of celestia itself. Let's see if we can fix this without adding those deps. Do you know any other distros which package the gtk variant ?
Comment by Alessandro Doro (adoroo) - Tuesday, 30 June 2009, 12:47 GMT
In the current system the bug is not present. Can someone confirm?
Comment by Ronald van Haren (pressh) - Tuesday, 30 June 2009, 12:51 GMT
yes confirmed on two machines (i686 and x86_64), seems it has resolved itself. I close this bug.

Loading...