Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13352 - Can't print anymore since the latest hplip upgrade

Attached to Project: Arch Linux
Opened by Joël Schaerer (lardon) - Wednesday, 18 February 2009, 07:12 GMT
Last edited by Aaron Griffin (phrakture) - Wednesday, 18 February 2009, 17:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Since the latest upgrade of hplip, I can't print anymore. Cups gives a rather unuseful error message:

"/usr/lib/cups/filter/foomatic-rip failed"

Some additional investigations revealed that all the various hp-* commands fail with the following error:

error: HPMUDEXT could not be loaded. Please check HPLIP installation.

There is at least one other person affected by the bug: http://bbs.archlinux.org/viewtopic.php?pid=500769#p500769

Additional info:
* package version(s)
joel@mouton Season 3$ pacman -Qi hplip cups
Name : hplip
Version : 2.8.12-1
URL : http://hplip.sourceforge.net
Licenses : GPL
Groups : None
Provides : None
Depends On : cups python ghostscript foomatic-db foomatic-db-hpijs foomatic-db-engine libcups
Optional Deps : sane: for scanner support
net-snmp and portmap: for network support
pyqt3: for running hp-toolbox
Required By : None
Conflicts With : None
Replaces : hpijs
Installed Size : 52228.00 K
Packager : Tobias Powalowski <tpowa@archlinux.org>
Architecture : i686
Build Date : Wed 11 Feb 2009 03:30:01 PM CET
Install Date : Tue 17 Feb 2009 09:12:28 PM CET
Install Reason : Explicitly installed
Install Script : Yes
Description : Drivers for HP DeskJet, OfficeJet, Photosmart, Business Inkjet and some LaserJet.

Name : cups
Version : 1.3.9-4
URL : http://www.cups.org/
Licenses : GPL
Groups : None
Provides : None
Depends On : acl openslp pam libcups>=1.3.9 xdg-utils avahi heimdal>=1.2.1-3 gnutls>=2.6.3
Optional Deps : None
Required By : hplip pycups
Conflicts With : None
Replaces : None
Installed Size : 16180.00 K
Packager : Andreas Radke <andyrtr@archlinux.org>
Architecture : i686
Build Date : Sat 17 Jan 2009 10:35:09 PM CET
Install Date : Sun 18 Jan 2009 06:21:34 PM CET
Install Reason : Explicitly installed
Install Script : Yes
Description : The CUPS Printing System

My printer is an hp photosmart 7260, and I access it through a small belkin printer server.
This task depends upon

Closed by  Aaron Griffin (phrakture)
Wednesday, 18 February 2009, 17:32 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#13294 
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 18 February 2009, 07:17 GMT
Hi, maybe the problem is that don't have the net-snmp package installed.

The file /usr/lib/libhpmud.so.0.0.4 depends on it.

$ ldd /usr/lib/libhpmud.so.0.0.4
linux-gate.so.1 => (0xb7fd4000)
libusb-0.1.so.4 => /usr/lib/libusb-0.1.so.4 (0xb7ecb000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb7eb3000)
libnetsnmp.so.15 => /usr/lib/libnetsnmp.so.15 (0xb7e07000)
libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0xb7cb1000)
libc.so.6 => /lib/libc.so.6 (0xb7b69000)
/lib/ld-linux.so.2 (0xb7fd5000)
libdl.so.2 => /lib/libdl.so.2 (0xb7b65000)
libz.so.1 => /usr/lib/libz.so.1 (0xb7b51000)

Check this.
Comment by Bernd Pol (bernarcher) - Wednesday, 18 February 2009, 12:17 GMT
Confirmed. Adding the net-snmp package did the trick.

Shouldn't it added to the hplip package dependencies?

Loading...