Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13223 - Xlib throws several errors while starting a program, that needs it

Attached to Project: Arch Linux
Opened by Dirk Sohler (dsohler) - Thursday, 12 February 2009, 06:31 GMT
Last edited by Jan de Groot (JGC) - Thursday, 12 February 2009, 15:04 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 11
Private No

Details

Description:

For example: If i start Firefox out of an terminal emulation window, the output in this window is …

Xlib: extension "Generic Event Extension" missing on display ":0.0".
Xlib: extension "Generic Event Extension" missing on display ":0.0".
Xlib: extension "Generic Event Extension" missing on display ":0.0".
Xlib: extension "Generic Event Extension" missing on display ":0.0".
Xlib: extension "Generic Event Extension" missing on display ":0.0".
Xlib: extension "Generic Event Extension" missing on display ":0.0".

… and this happens too, if i start other tools, that have its own window (i guess, that happens everytime i start a tool, that needs the Xlib)

Besides this error messages the program starts as expected.


Additional info:

$ uname -srvm
Linux 2.6.28-ARCH #1 SMP PREEMPT Sun Feb 8 09:47:26 UTC 2009 x86_64

libx11 version: 1.1.99.2-2


Steps to reproduce:

Update your system to the current state and run a program that needs the Xlib out of a terminal emulation window.
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 12 February 2009, 15:04 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Thursday, 12 February 2009, 08:11 GMT
This is because the libraries support an extension that isn't supported by the X server yet. This message is harmless and can be ignored.
Comment by Dirk Sohler (dsohler) - Thursday, 12 February 2009, 13:17 GMT
harmless and annoying. more annoying than harmless, i guess.

Loading...