Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13185 - [xine-lib] The newest version breaks flac playback

Attached to Project: Arch Linux
Opened by Brendan Fahy (f4hy) - Tuesday, 10 February 2009, 09:44 GMT
Last edited by Eric Belanger (Snowman) - Wednesday, 24 February 2010, 17:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
The newest version of xine-lib breaks flac playback

Additional info:
This is a regression with xine-lib from 1.1.15 to 1.1.16.
Upstream bug report http://bugs.xine-project.org/show_bug.cgi?id=196

Steps to reproduce:
Try to play a flac file with an audio application which uses xine-lib. E.g. amarok
This task depends upon

Closed by  Eric Belanger (Snowman)
Wednesday, 24 February 2010, 17:45 GMT
Reason for closing:  Fixed
Comment by Pierre Schmitz (Pierre) - Tuesday, 10 February 2009, 09:47 GMT
Strange, I can play flac files with dragon or kaffeine without problems.
Comment by Brendan Fahy (f4hy) - Tuesday, 10 February 2009, 09:49 GMT
Hmm that is odd. I am able to play flac with other apps just not amarok, but it does work if I downgrade to 1.1.15. I get the same error messages as the user in the upstream bug.
Comment by Eric Belanger (Snowman) - Thursday, 12 February 2009, 02:23 GMT
amarok plays flac files fine here. Try xine-lib-1.1.16.2-1. Maybe it'll work with this one.
Comment by Brendan Fahy (f4hy) - Thursday, 12 February 2009, 05:19 GMT
I am running 1.1.16.2-1 and I still have issues. It is weird though it does not completely fail the play the file, just starts it at a random position and attempting to play them from the start causes it to fail and skip the whole track. It is random each time how much it skips and sometimes plays just fine. When it fails on a file it dumps a ton of errors to the console, I can provide them if it helps. Perhaps it is something to do with the particular flac files I have? is there some tool to dump debug information about flac files? They work just fine in other players so I know they are not bad, but still would like to check somehow.
Comment by Jan de Groot (JGC) - Friday, 13 February 2009, 18:22 GMT
According to http://bugs.archlinux.org/task/13257, the new version of xine-lib has two flac decoders. This might be a pointer to the real problem behind this bug.
Comment by Sander Jansen (GogglesGuy) - Friday, 13 February 2009, 18:32 GMT
regular stereo FLAC playback in my Goggles Music Manager works fine. "[flac @ 0x1946eb0]" type of error messages comes from ffmpeg, so it might be related to ffmpeg.
What you can try is to remove the xineplug_decode_ff.so from the xine plugin directory and see if libFLAC plugin has the same problem.

Note I don't think 13257 is really a duplicate. I think we have been distributing two flac decoders for a while now.
Comment by Sander Jansen (GogglesGuy) - Monday, 20 April 2009, 14:53 GMT
The new ffmpeg 0.5 package seems to solve the issue for me. (at least all the warning/error messages seem to be gone now).
Comment by Sander Jansen (GogglesGuy) - Monday, 20 April 2009, 15:02 GMT
Actually... it is not fixed. I think flac playback in ffmpeg is just broken....
Comment by Todd Partridge (Gen2ly) - Monday, 22 June 2009, 19:17 GMT
Could this package's description be updated too? As it is now "A free video player for Unix" is inaccurate, be more accurate to describe as, "A multimedia playback engine".
Comment by Sander Jansen (GogglesGuy) - Friday, 22 January 2010, 19:07 GMT
This bug still very much exists:

[flac @ 0x2388610]FRAME HEADER not here
[flac @ 0x2388610]invalid predictor order: 16 > 0
[flac @ 0x2388610]decode_frame() failed
[flac @ 0x2388610]FRAME HEADER not here
Last message repeated 1 times

I believe the next version of xine should automatically use the libflac decoder instead.
Comment by Eric Belanger (Snowman) - Wednesday, 24 February 2010, 06:23 GMT
It looks like it's fixed in xine-lib-1.1.18-1. From the release notes:

* Bump the FLAC decoder's priority above ffmpegaudio. This should fix
various problems with FLAC playback.

Could you test and confirm?
Comment by Sander Jansen (GogglesGuy) - Wednesday, 24 February 2010, 17:28 GMT
Tested it and confirmed it works now correctly.

Thanks!

Loading...