FS#13163 - hal 0.5.11-7 umount in xfce: problem

Attached to Project: Arch Linux
Opened by ugaciaka (ugaciaka) - Sunday, 08 February 2009, 16:42 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 14 April 2009, 21:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


with hal I have a problem with the mount / umount solved with this system in /etc/PolicyKit/PolicyKit.conf

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->

<!DOCTYPE pkconfig PUBLIC "-//freedesktop//DTD PolicyKit Configuration 1.0//EN"

<!-- See the manual page PolicyKit.conf(5) for file format -->

<config version="0.1">
<match action="org.freedesktop.hal.storage.mount-removable">
<return result="yes" />
<match action="org.freedesktop.hal.storage.eject-removable">
<return result="yes" />
<match action="org.freedesktop.hal.storage.mount-fixed">
<return result="yes"/>
<match action="hal-storage-mount-fixed-extra-options">
<return result="yes"/>
<match action="hal-storage-mount-removable-extra-options">
<return result="yes"/>

Only that I am having problems xfce to eject the cd/dvd

"Device to unmount is not in /media/.hal-mtab so it is not mounted by HAL" and i eject cd only hardware way...
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 14 April 2009, 21:53 GMT
Reason for closing:  Not a bug
Comment by Andreas Radke (AndyRTR) - Monday, 16 February 2009, 16:28 GMT
same as #10385?
Comment by ugaciaka (ugaciaka) - Monday, 16 February 2009, 17:08 GMT
yes, solved in .xinitrc
exec ck-launch-session xfce4-session