Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13134 - [attr] download URL no longer works

Attached to Project: Arch Linux
Opened by Peter Simons (peti) - Friday, 06 February 2009, 09:50 GMT
Last edited by Eric Belanger (Snowman) - Monday, 07 December 2009, 05:30 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

simons@overkill attr]$ makepkg -g
==> Retrieving Sources...
-> Downloading attr_2.4.41-1.tar.gz...
--2009-02-06 10:49:58-- ftp://oss.sgi.com/projects/xfs/cmd_tars/attr_2.4.41-1.tar.gz
=> `attr_2.4.41-1.tar.gz.part'
Resolving oss.sgi.com... 192.48.182.195
Connecting to oss.sgi.com|192.48.182.195|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done. ==> PWD ... done.
==> TYPE I ... done. ==> CWD /projects/xfs/cmd_tars ... done.
==> SIZE attr_2.4.41-1.tar.gz ... done.
==> PASV ... done. ==> RETR attr_2.4.41-1.tar.gz ...
No such file `attr_2.4.41-1.tar.gz'.

==> ERROR: Failure while downloading attr_2.4.41-1.tar.gz
Aborting...
This task depends upon

Closed by  Eric Belanger (Snowman)
Monday, 07 December 2009, 05:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  the sources are now on local ftp
Comment by Greg (dolby) - Friday, 27 February 2009, 18:49 GMT
  • Field changed: Percent Complete (100% → 0%)
Only the latest sources are hosted on the project ftp. It would be better to host them on the ftp.archlinux.org/other dir so that they are always available. Same for acl.
Comment by Aaron Griffin (phrakture) - Friday, 27 February 2009, 18:50 GMT
I'd agree with this - to prevent being unable to build ABS PKGBUILDS, we should host shitty source like this
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 19 June 2009, 08:58 GMT
manby sources of core/extra are in FTP now, this task can be closed ?
Comment by Greg (dolby) - Friday, 19 June 2009, 19:41 GMT
The reason this was (re)opened was that these projects (attr & acl) dont keep older versions of their source code on the ftp so if they are out of date ABS will fail.
I have no problem with closing this, but for people wanting to use ABS the build will fail when that happens.
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 19 June 2009, 19:57 GMT
Ok I understand. By the way, the old tar files are in ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/ the problem is can especify multiple sources for the same file in source array in case of one fails. (maybe this can be an interesting feature for makepkg)

Loading...