Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13078 - pm-utils contains bug in pkgconfig file

Attached to Project: Arch Linux
Opened by Ronald van Haren (pressh) - Sunday, 01 February 2009, 13:39 GMT
Last edited by Thayer Williams (thayer) - Sunday, 01 February 2009, 20:23 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Thayer Williams (thayer)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: pkg-config --list-all fails due to bug in the pm-utils pkgconfig file (/usr/lib/pkgconfig/pm-utils.pc)

* package version(s): 1.2.3-3

Steps to reproduce:
pkg-config --list-all errors due to pm-utils.pc file

patch attached for the .pc file (it's really just a one character typo)
This task depends upon

Closed by  Thayer Williams (thayer)
Sunday, 01 February 2009, 20:23 GMT
Reason for closing:  Implemented
Additional comments about closing:  Pushed
Comment by Ronald van Haren (pressh) - Sunday, 01 February 2009, 13:45 GMT
Upstream report btw:pm-utils@lists.freedesktop.org/msg01759.html"> http://www.mail-archive.com/pm-utils@lists.freedesktop.org/msg01759.html
Comment by Thayer Williams (thayer) - Sunday, 01 February 2009, 19:07 GMT
Thanks pressh! Is it going to cause any major headaches if I skip this patch locally? They've already committed it upstream so if it's not a big deal I'll wait until the next release.
Comment by Ronald van Haren (pressh) - Sunday, 01 February 2009, 19:49 GMT
Miro is not buildable without that patch. I don't think there are much other packages using that method to see if all deps are installed. I don't know about the pm-utils release frequency, depending on it see if you want to fix it. I'll work around it locally for the time being.

Loading...