Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13074 - pkgconfig configuration file currupted

Attached to Project: Arch Linux
Opened by Maxime de Roucy (akira86) - Saturday, 31 January 2009, 20:50 GMT
Last edited by Ronald van Haren (pressh) - Sunday, 01 February 2009, 17:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

pkg-config configuration file /usr/lib/pkgconfig/pm-utils.pc there is a ")" instead of an "}" which make compilation of some software crash.

I was working on a another bug http://bugs.archlinux.org/task/12022 and I can't managed to compile miro... that's how I found this bug.

Additional info:
* package version : 0.23-1

/usr/lib/pkgconfig/pm-utils.pc :
before, line 9 : pm_powerhooks=${pm_libdir)/power.d
after(solve), line : pm_powerhooks=${pm_libdir}/power.d

It's not hard to solve but I think is important to signal this bug in order to update the pkgconfig package.
This task depends upon

Closed by  Ronald van Haren (pressh)
Sunday, 01 February 2009, 17:22 GMT
Reason for closing:  Duplicate
Additional comments about closing:  duplicate of  FS#13078  (actually the other way around but that one contains a link to the upstream report. Sorry I did not see this report.)
Comment by Maxime de Roucy (akira86) - Saturday, 31 January 2009, 20:52 GMT
sorry, I was working on this bug http://bugs.archlinux.org/task/13072 ; not the other one.
Comment by Greg (dolby) - Saturday, 31 January 2009, 23:22 GMT
This is an upstream bug. Please report there too.

Loading...