Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13072 - miro crash after each video (doesn't matter which player it's used)

Attached to Project: Arch Linux
Opened by Maxime de Roucy (akira86) - Saturday, 31 January 2009, 16:34 GMT
Last edited by Ronald van Haren (pressh) - Sunday, 22 February 2009, 22:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture x86_64
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Miro crash after each video playing.

Additional info:
* package version : 1.2.8-2

Steps to reproduce:
just watch a video until the end...
It appear that it doesn't crash exactly when the video stop but when (after a video playing) the program try to display the video list of the channel. It is the same during a video, when I try to switch to another channel -> miro crash.

If I don't play video -> everything work well.

(this bug appear at the same time as http://bugs.archlinux.org/task/12872 resolved thanks to Snowman :-))

in attachment a strace, the std output, the std error, and both (output+error).
   strace (15.7 KiB)
   output (4 KiB)
   error (35.2 KiB)
   everything (39.2 KiB)
This task depends upon

Closed by  Ronald van Haren (pressh)
Sunday, 22 February 2009, 22:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in 2.0.1
Comment by Maxime de Roucy (akira86) - Saturday, 31 January 2009, 16:38 GMT
oups I forgot : I try to recompile miro ... but the compilation crash.
Comment by Ronald van Haren (pressh) - Sunday, 01 February 2009, 14:10 GMT
Your compilation crash is probably related to  FS#13078 , but don't bother it won't fix your problem.

Miro<=1.2.8 seems to be incompatible with xine-lib 1.1.16 as it appears from some related reports [1] and [2]. Miro 2 should be released shortly which should not have this problem fixed if we are to believe those reports. I'll see how stable miro 2 release candidate is and maybe update to that.
In the meantime the gstreamer backend should work just fine.

[1] http://getsatisfaction.com/participatoryculturefoundation/topics/miro_segfaults_after_each_video
[2] https://bugzilla.redhat.com/show_bug.cgi?id=480527
Comment by Ronald van Haren (pressh) - Sunday, 01 February 2009, 14:22 GMT
you say it doesn't matter which backend is used? please try with a clean config directory and see if that remains the case (you need to restart miro after you change the backend for it to take effect)

[edit] about miro 2rc, I spoke to soon, it appears to have the same bug
Comment by Maxime de Roucy (akira86) - Sunday, 01 February 2009, 17:15 GMT
I solve the compilation problem : http://bugs.archlinux.org/task/13074

but, like you said, it haven't solve the problem.

I try with a clean config directory (~/.miro and ~/.gconf/apps/miro) but it's the same, after launching a video I am not able to go back to a channel.
Comment by Maxime de Roucy (akira86) - Thursday, 12 February 2009, 06:22 GMT
I just solve the problem by installing gstreamer0.10-python ... I think a notification should appear at the installation of Miro in order to inform those who want to use gstreamer to install this package !!
Comment by Ronald van Haren (pressh) - Sunday, 15 February 2009, 23:27 GMT
re-opening, the xine backend is still broken, also in the final miro 2.0 release.

Loading...