Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#13070 - grub-gfx installed instead of default grub

Attached to Project: Release Engineering
Opened by dyscoria (dyscoria) - Saturday, 31 January 2009, 15:18 GMT
Last edited by Dieter Plaetinck (Dieter_be) - Wednesday, 11 February 2009, 17:59 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Aaron Griffin (phrakture)
Gerhard Brauer (GerBra)
Dieter Plaetinck (Dieter_be)
Architecture All
Severity Medium
Priority Normal
Reported Version 2009.01-beta
Due in Version 2009.02
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

From what i can see in the ML, grub-gfx is installed instead of default grub (I haven't looked at the ISO's myself though so _please_ correct me if i'm wrong).

I feel that default grub should be used, as the user can choose afterwards if he/she wants a graphical grub screen. I'm especially concerned with the reliance on a package from [community] for a default install.
This task depends upon

Closed by  Dieter Plaetinck (Dieter_be)
Wednesday, 11 February 2009, 17:59 GMT
Reason for closing:  Duplicate
Additional comments about closing:  dup of  FS#13057 
Comment by Gerardo Exequiel Pozzi (djgera) - Saturday, 31 January 2009, 20:23 GMT
This patch for /arch/setup executes the correct grub (not grub-gfx) to install in the MBR/BOOT.
Comment by Dieter Plaetinck (Dieter_be) - Saturday, 31 January 2009, 22:41 GMT
Thanks Gerardo, the patchs looks okay to me.
Alexander also confirmed it works.
Comment by Dieter Plaetinck (Dieter_be) - Saturday, 31 January 2009, 22:44 GMT
I assigned some developers to this. is there anyone who can apply the above patch and release a new archlinux-installer package?
Comment by Dan McGee (toofishes) - Saturday, 31 January 2009, 23:28 GMT
Patch pushed, but I didn't rebuild the packages because it looks to be a rather long process and I want to make sure Aaron doesn't have anything else he needs to get in here.
Comment by Gerhard Brauer (GerBra) - Monday, 09 February 2009, 13:57 GMT
Fixed in 2009.02-RC1 (patch applied on the ISOs)
@Aaron: you would build a new installer package 2009.02
Comment by Aaron Griffin (phrakture) - Monday, 09 February 2009, 16:48 GMT
Wow, why is this assigned to so many people?
Comment by Dieter Plaetinck (Dieter_be) - Monday, 09 February 2009, 18:56 GMT
Aaron, I needed to pull attention from some people with access to the archlinux-installer package when you were away :)
Since Dan helped me out, I'll clean up the list now :)

Loading...