Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#13057 - Use bootloader from the installed system

Attached to Project: Release Engineering
Opened by Aaron Griffin (phrakture) - Friday, 30 January 2009, 23:38 GMT
Last edited by Dieter Plaetinck (Dieter_be) - Saturday, 14 February 2009, 12:21 GMT
Task Type Bug Report
Category archlinux-installer (deprecate
Status Closed
Assigned To Aaron Griffin (phrakture)
Gerhard Brauer (GerBra)
Dieter Plaetinck (Dieter_be)
Architecture All
Severity Low
Priority Normal
Reported Version 2009.01-beta
Due in Version 2009.02
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

It looks like our current install uses the grub-install command from OUTSIDE the installed system. We should probably be using the grub from the newly installed system (or lilo).
This task depends upon

Closed by  Dieter Plaetinck (Dieter_be)
Saturday, 14 February 2009, 12:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  confirmed by http://www.archlinux.org/pipermail/arch- releng/2009-February/000327.html
Comment by Aaron Griffin (phrakture) - Friday, 30 January 2009, 23:40 GMT
It looks like this causes some issues... showstopper?
Comment by Dieter Plaetinck (Dieter_be) - Saturday, 31 January 2009, 10:29 GMT
Which issues? Do you mean this http://www.archlinux.org/pipermail/arch-releng/2009-January/000175.html ?
any specific reason why it's better to chroot to the new system?
Comment by Gerhard Brauer (GerBra) - Saturday, 31 January 2009, 10:30 GMT
I don't ever see that this makes a general problem when grub(-gfx) and grub are on the same patch/version level.

Current issue on x86_64 systems are affected cause the x86_64 version of grub-gfx wasn't on the same version as i686. This was reported on arch-releng ML (and the OP could solve it by rebuilding grub-gfx with all patches).
grub-gfx 0.97-7 on x86_64 lacks the bigger-inode size patch, that's the reason for not installing.

Generally i saw no advantage or disadvantage using the "inside" or "outside"(liveCD) bootloader to use - when they are on the same level. If we were using the "inside" we would have *this* mentioned problem (bad version on x86_64) also...
Comment by Gerhard Brauer (GerBra) - Saturday, 31 January 2009, 12:31 GMT
Additional info inside vs. outside:
I have a quick look on our installer (I were unsure how we call what...) and see: we already use the "inside" grub to install bootloader:
$DESTDIR/sbin/grub-install --recheck --root-directory=$DESTDIR $ROOTDEV >/tmp/grub.log 2>&1
DESTDIR is /mnt.

But then the problem could not be grub-gfx...

//Edit: Sorry, my fault. grub-install is only a shell script which calls grub. And this is in the end /sbin/grub and so the grub-gfx binary...
Comment by Aaron Griffin (phrakture) - Wednesday, 11 February 2009, 17:09 GMT
  • Field changed: Status (Researching → Requires Testing)
  • Field changed: Due in Version (Undecided → 2009.02)
Should be fixed in archlinux-installer 2009.02-2 and will be in RC2. Please test
Comment by Dieter Plaetinck (Dieter_be) - Wednesday, 11 February 2009, 17:59 GMT
for the applied patch, see  FS#13070 

Loading...