Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#13035 - Report installed dependencies on opt-depends showing

Attached to Project: Pacman
Opened by kongokris 2 (nut543) - Thursday, 29 January 2009, 14:42 GMT
Last edited by Allan McRae (Allan) - Friday, 14 December 2012, 02:49 GMT
Task Type Feature Request
Category General
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version 4.1.0
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

would be nice to have output like(on upgrade/install of packages):

(3/9) upgrading bluez [##################################################################################################] 100%
Optional dependencies for bluez
gstreamer0.10-base: non-installed
alsa-lib: installed
libusb: non-installed

for example. or even signify installed/not-installed with colors if that ever gets implemented..

to atleast have some indicator wether you have or don't have the package would speed up the process of installing packages because you don't have to check if you have the opt-depends installed(i don't think anybody remembers every package they have installed.)

but this is low-prio and devs can decide if they want to add this or not(obviously they could anyway since they hold the source :P)
This task depends upon

Closed by  Allan McRae (Allan)
Friday, 14 December 2012, 02:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  git commit 8e736e1c
Comment by Gavin Bisesi (Daenyth) - Friday, 20 March 2009, 14:53 GMT
My preference would be for optdepends to not be displayed at all if the package in question is installed.
Comment by Aaron Griffin (phrakture) - Friday, 20 March 2009, 16:39 GMT
Hmm, I would still prefer to see it, but like so:

Optional dependencies for foobar
abiword: for doing thingers
alsa-lib: makes dingy things and beeps (installed)
python: plugin support (installed)
Comment by Gavin Bisesi (Daenyth) - Friday, 20 March 2009, 16:47 GMT
Well, my line of thinking on it is this: optdepends are displayed upon installation to inform the user of added functionality they can add. If it's already installed, there's no need to inform, and so the optdepends are just additional spam that doesn't need to be shown. Full optdepends could be shown for pacman -Qi.
FS#12708 may or may not be related, depending on your views.
Comment by Aaron Griffin (phrakture) - Friday, 20 March 2009, 17:07 GMT
Well, how about if someone says "bah I don't use PNG support in foobar" and then notices it's an optdepend and thus can be uninstalled safely?
Comment by Gavin Bisesi (Daenyth) - Friday, 20 March 2009, 17:12 GMT
How was it installed in the first place then? pacman -Qi should show the option dependency status so that they know to remove it, if for example they notice it getting upgraded.
Comment by Aaron Griffin (phrakture) - Friday, 20 March 2009, 17:29 GMT
You're assuming people have good memories... what if they installed it and wait 3 months
Comment by Gavin Bisesi (Daenyth) - Friday, 20 March 2009, 17:37 GMT
Perhaps make it configurable which way it would display it? I agree that displaying installed or not installed for optdepends would be better than the current behavior, but I think better yet would be not at all. I guess it's a matter of taste.
Comment by Allan McRae (Allan) - Saturday, 21 March 2009, 15:43 GMT

Loading...