Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13027 - mpd needs lame as dependency

Attached to Project: Arch Linux
Opened by Uli (Army) - Thursday, 29 January 2009, 00:02 GMT
Last edited by Alexander Fehr (pizzapunk) - Thursday, 29 January 2009, 23:07 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Alexander Fehr (pizzapunk)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I just did a fresh install, installed my xfce and temporarely installed kde4.2 (kdemod version) to test it a little bit. After uninstalling it again, mpd didn't work any more. Running mpd on the terminal gave this output

$ mpd
mpd: error while loading shared libraries: libmp3lame.so.0: cannot open shared object file: No such file or directory

This is included in lame

Additional info:
* package version(s)

$ pacman -Qi mpd|grep Version
Version : 0.14.1-3
$ pacman -Qi lame|grep Version
Version : 3.98.2-1

* config and/or log files etc.

nope

Steps to reproduce:
Check the dependencies of mpd and see, that lame isn't included. Uninstall lame and do a /etc/rc.d/mpd restart and see it fail. Trying to run it with simply "mpd" as command shows the missing lib.
   . (0 KiB)
This task depends upon

Closed by  Alexander Fehr (pizzapunk)
Thursday, 29 January 2009, 23:07 GMT
Reason for closing:  Not a bug
Comment by Andrea Scarpino (BaSh) - Thursday, 29 January 2009, 08:18 GMT
mpd requires ffmpeg who requires lame
Comment by Uli (Army) - Thursday, 29 January 2009, 18:00 GMT
Ah damn, I'm sorry, I have my own ffmpeg and of course I missed adding lame to the dependency list. Topic closed, me in shame ;)
   . (0 KiB)

Loading...