Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12967 - xsp 2.0-1 build error

Attached to Project: Arch Linux
Opened by Baho Utot (baho-utot) - Sunday, 25 January 2009, 13:31 GMT
Last edited by Isenmann Daniel (ise) - Monday, 26 January 2009, 05:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture All
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

make[3]: Leaving directory `/srv/http/Build/BUILD.i686/extra/xsp/src/xsp-2.0/test/1.1/asp.net'
Making all in webcontrols
make[3]: Entering directory `/srv/http/Build/BUILD.i686/extra/xsp/src/xsp-2.0/test/1.1/webcontrols'
/usr/bin/mcs -debug:full -r:Mono.Data.SqliteClient.dll -out:dbpage_test_setup.exe dbpage_test_setup.cs
/usr/bin/mono dbpage_test_setup.exe

Unhandled Exception: System.DllNotFoundException: libsqlite3.so.0
at (wrapper managed-to-native) Mono.Data.SqliteClient.Sqlite:sqlite3_open16 (string,intptr&)
at Mono.Data.SqliteClient.SqliteConnection.Open () [0x00000]
at App.Main () [0x00000]
make[3]: *** [dbpage1.sqlite] Error 1

Additional info:
package version xsp 2.0-1
This task depends upon

Closed by  Isenmann Daniel (ise)
Monday, 26 January 2009, 05:28 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See last comment.
Comment by Isenmann Daniel (ise) - Sunday, 25 January 2009, 15:45 GMT
Why would you build xsp 2.0. There is a new version 2.2 in the repos, which build fine with mono 2.2.
Comment by Baho Utot (baho-utot) - Sunday, 25 January 2009, 22:14 GMT
I am rebuilding the entire extra repos for the AMD platform using the latest tool chain.

The xsp 2.0 was in the abs repos at the beginning of January when I started the project.

After the project is completed I am going to update abs once a week on day 0, then I have a script that will rebuild anything new and place into my custom repos.
Comment by Isenmann Daniel (ise) - Monday, 26 January 2009, 05:28 GMT
You can't rebuild xsp 2.0 with mono 2.2. I will close this bug, because this is not a bug. For example, Monodevelop 1.0 can't be build with mono 2.2, only the new svn-snapshots are buildable. So, this is more a combatible issue between the releases.

Loading...