Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12965 - virtualbox-module misses vboxnetflt

Attached to Project: Community Packages
Opened by Hao Chi Kiang (woodykiang) - Sunday, 25 January 2009, 13:10 GMT
Last edited by Ionut Biru (wonder) - Wednesday, 22 April 2009, 13:31 GMT
Task Type Bug Report
Category
Status Closed
Assigned To Geoffroy Carrier (gcarrier)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:
There is no vboxnetflt in both virtualbox-ose and virtualbox-module. As a result, the host interface networking never works.

Additional info:
* package version(s)
community/virtualbox-modules 2.1.2-1
community/virtualbox-ose 2.1.2-1

* config and/or log files etc.
See here:
http://bbs.archlinux.org/viewtopic.php?pid=486464#p486464

Steps to reproduce:
Install virtualbox-ose and then start a VM that is use host interface networking.
This task depends upon

Closed by  Ionut Biru (wonder)
Wednesday, 22 April 2009, 13:31 GMT
Reason for closing:  Implemented
Additional comments about closing:  virtualbox-modules 2.2.0-1
Comment by robin martinjak (robmaloy) - Tuesday, 27 January 2009, 07:32 GMT
simple "patch" to add the following:

install -D -m644 vboxnetflt.ko "$pkgdir/lib/modules/${_kernver}/misc/vboxnetflt.ko"
Comment by Tomas Hejatko (Arteal) - Thursday, 19 February 2009, 18:16 GMT
Yes, this is serious issue, with (i think) easy fixing, please complete this soon :)
Comment by Luiz (netuno55) - Monday, 16 March 2009, 02:33 GMT
Please fix this. vboxnetflt is an important module as it enables Host Interface network. Thanks!
Comment by Jared (nitro) - Monday, 16 March 2009, 13:16 GMT
Has anyone looked at this? There seems to have been zero activity on this since it was reported.
Comment by Sergio (SergioPR) - Thursday, 26 March 2009, 23:10 GMT
I also think it would be a great idea to add vboxnetflt to this package. Please, add it :D
Thanks!
Comment by Jared (nitro) - Friday, 10 April 2009, 18:38 GMT
Is there anyone else that can address this bug since the current assignee is unresponsive? In addition to preventing a virtualbox upgrade, this bug is also preventing me from upgrading my kernel, numerous kernel-related packages, and my nvidia drivers due to dependency issues.
Comment by Tomas Hejatko (Arteal) - Sunday, 12 April 2009, 17:04 GMT
pacman -Syu now gives me "error: failed to prepare transaction (could not satisfy dependencies)
:: virtualbox-modules: requires kernel26<2.6.29"

Loading...